Google Sheets Reader not seeing most recent files

Hey all,

First time trying to connect to Google using Knime. I had some trouble initially getting connected, but now can connect via Google Authenitcation and Google Sheets Connector.

Screen Shot 2022-12-05 at 1.21.35 PM

However, when I try to get my sheet via the Google Sheets Reader, it’s like it has cached an older version of my sheets files. I see most of the recent sheets that are in Google Sheets (both sheets that I own and sheets that were shared with me), but not the sheets that I need.

Any idea what is going on? I’d love some help to figure this one out!

Hi @nchemby1996 and welcome to the KNIME Forum!

I run a quick test and everything seems to work fine for me.
One thing you might try - so that we can exclude is not a problem of permission/sharing:

  • Retrieve the spreadsheetID. Opening the sheet in the browser, you can copy it from the URL (highlighted in the picture below)

  • Create a flow variable holding the spreadsheetID value

  • Use the created variable in the Google Sheet Reader node to select the desired spreadsheet.

Let me know how it goes and we can investigate from there :slight_smile:


1 Like

I tried this and got the following error when I tried to apply:

Any other ideas?

@emilio_s on further examination it looks like there may be an issue with accessing files in a shared drive. See my list of files available in the node:

versus the files in my Google Sheets web page:

All the items missing are located in a shared drive.

Hi @nchemby1996, You are right, spreadsheets from a shared drive are currently not shown in the Google Sheets Reader node. There is an open ticket for that already (AP-11391 for internal reference), I am adding a +1 for your request and keep you posted, thank you for pointing this out.
In the meantime, you can use a workaround by setting the flow variable as I described in my previous message. Regarding the error message “Spreadsheet ID must not be empty” you can fix it by first selecting a random spreadsheet from the list. The selection will then be replaced by the id provided in the flow variable.

From the other screenshot, I see that some of the sheets you are trying to access are in .xlsx format. In order to read those, you would have to use the Google Drive Connector and Excel Reader nodes, since they are not supported by the Google Sheets Reader node.

I hope this helps!



Good to know, thanks @emilio_s! Another workaround my manager and I found is that you can also access shared drive files by using Google Drive for desktop. By using an Excel Reader node, you can go into all of your Google Drive files on your desktop and select files from there.

Thanks for the help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.