Group Loops executing the same data twice

Hello, all,

I’ve been using knime for a while to generate forescats. However, sometimes I’ve been facing a problem: the group loop is executing the same dataset twice, and this problem causes duplicated rows (in the historical data and forecasts) in the output.

This error doesn’t occour always, only sometimes. Do you have an idea of what can be causing this problem?


Hi @LahysPortugal , this is most likely your grouping that is not being done correctly.

If you can show us your workflow and your Group Loop configuration, along with some sample data (input) and the results where you are seeing duplicates, we will be able to point out why this is happening.

This is my workflow. In this case I use the loop to complete the temporal dataset. In this picture I have two examples. I executed the same loop workflow for the same data input. In the superior workflow it worked perfectly. But in the second one I had the problem.

I noted that in the first one, I had 1317 iterations, which is the number of combinations I had. But in the second one I had 1551. When I filter one case in the outputs and goup it by month, I have those values, for the same time in past:

I assumed that it had occourred because of the increasing in loop iterations. But as the workflows are the same I don’t know what can be causing it.

(I only had the second workflow first, but I created the first one to evaluate if it would generate the right output and compare, to try to find the reason. But I literally ctrl+C ctrl+V the original, and after doing this it worked perfectly).

Can you please show us your Group Loop configurations?

And what’s the difference between the 2? Is it just the Loop End (one being the deprecated version)? Can you also share the configurations of both Loop End nodes?

Grou Loop Start:

Loop End:

Both workflow are equal. I don’t think that using the deprecated version is the problem, because as I said, This error isn’t happening every time. Even when I execute the second workflow sometimes it works, sometimes it doesn’t (in fact, most part of time the problem doesn’t occour). I’m sure this is an error. I am trying to find a reason on why it is occouring. Maybe because I was working in another files at the same time, and the program stopped responding for a while… something like that.

And the nodes from Concatenate to Rule Engine between the 2 Loops do the same thing in both Loops?

EDIT: Also, the results that you showed, are these the output of the Loop Ends, or are they results of nodes further down?

1 Like


I also noticed this behavior with loop nodes. Sometimes I feel that it happens when an error occurs inside the loop (some node has an error, I correct it and run the loop again) … In this cases the best thing is to reset the entire workflow not only the loop part.


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.