Having troubles with Reaction nodes again

Hi All,

still struggle with the RDKIt Reaction/transformation nodes.

I don’t want to to a “real” reaction. Currently I’m simply looking to replace a specific functional group (alcohol) with a dummy atom / attachment point.

I have a list of alcohols (only 1 per molecule) and a reaction [OH1]>>[A]

When I apply this with the One Component Reaction node I simply get “*” as result for all products even when uniquify products is selected. Same behavior with the Transformation node. So the nodes seem the replace the whole instead of just the matched group.

If I for example do [OH1]>>[N], the products all are NH2.

If try with mapping [OH1:1]>>[A:1] then the products simply are the same as the input molecules (One component reaction)

So how do I use these nodes properly for my purpose? I think a simple replacement node would help a lot?

Hi @beginner

I think that the Atom Replacer node would work for your purposes

I tried but it doesn’t because I want to strictly replace COH (alcohol) and not COC (ether) as example plus my replacement is not on atom level but functional group level.

Can you post the file with the molecules you’re trying to modify?

No I can’t.

I now got it solved by using to python script directly with Chem.ReplaceSubstructs. However even that this somewhat specific to my situation.