HELP! New spatial installation prevents KNIME from opening

I tried to install the software located here:, however, after restart KNIME does not open properly. I cannot see the toolbars and remove this software. Is there a way to either:

  1. Revert KNIME to the setup it was before this installation, or
  2. Delete the software from the backend so that it doesn’t open when KNIME tries to open?

A view of KNIME post-install (nothing shows up):

Thanks for your help!

So I ended up finding a way to revert the version as follows:

  1. From the help (only thing which worked), I searched for ‘install new software’
  2. From the window that came up, I clicked on ‘What is already installed?’
  3. Then selected the tab at the top called ‘Installation History’
  4. Selected a time before which I had downloaded the file above
  5. Clicked ‘Revert’ on the bottom
  6. Restarted and works like new!

If anyone has experience with that Spatial software - please advise if any suggestions to make it work? It looks like it is high potential, but not at the cost of disabling KNIME for more than an hour!

1 Like

Hi there,

which KNIME version are you using? I’m on 4.01 and just managed to install it successfully from KNIME Hub. Drag&Drop icon from the right into your running KNIME session. Make sure you have right update sites enabled. Check that under File --> Preferences --> Install/Update --> Available Software Sites. This extension is under community extensions Experimental…


Installation worked for me as well under KNIME 4.0.2. @supersharp, were you possibly using a KNIME version older than 3.7.2?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.