Help with Google Sheets viewer displaying character in different languages.

Hi @umutcankurt my settings is like yours, except that it shows Cp1252. But you can add whichever you want via the “Other” option.

For my Knime version, it’s the latest, 4.4.1.

I’m not sure how to solve this for you. Not sure if it’s Knime related, or system related. If it is the latter, upgrading to 4.4.1 will not change resolve this.


@umutcankurt I tried to read the data with the Excel Reader under Windows but it failed. With MacOSX and several nodes I think I can read the data and also it seems there are R packages that can read them as CSV and store the results in other formats like KNIME .table or ARFF or Parquet or SQLite which you might later use.

The (new) CSV reader although had a problem also under MacOSX.

So while R might not be the easiest option there could be a workaround.


Hi @mlauber71 ,

Do you mean it could not read the file, or that it was not displaying the strings correctly?

Which version of Knime are you running? I’m asking because I was able to open the file with the Excel Reader under Windows and it displayed properly too (please check my screenshots).

Why would it work for some and not for others…?

It did not display the correct characters under a Windows 10 system. Not sure why that is. I did experiment with Differenzen UTF settings. But to no avail.

1 Like

Thanks for the additional info @mlauber71 . I’m running on Windows 8.1.

The Excel Reader does not seem to offer character encoding option.

Are you able to open the file via Excel, copy the content and paste in 1) Knime’s Table Creator; and 2) A text file via notepad? Do the text display properly?

1 Like

Hi, there is something missing or strange somehow, but I’m sure I couldn’t find it about the version or a little setting. I hope you guys can find the reason for this slight difference.

@bruno29a I can open the file in Excel and copy the characters (so I was able to extract them and also have them in a ‘pure’ table). You can follow that in the /data/ folder of my example.

The Excel Reader does not read the characters neither in Windows 10 nor MacOSX. R does the job under Mac. I was not able to test it in Windows since KNIME gives strange messages about the R version (sad).

My; Windows 10 Home Single Language and KNIME 4.3.4

Which encoding did you use? I was not able to read it on window 10

Hi; @mlauber71 and @bruno29a
Airport.xlsx (52.5 KB)
In order to filter through the word list, I translate and update many languages ​​in google tables. I use it to filter the data by importing the word list into knime. I upgraded the knime version, I tried different ones, but I couldn’t get it to display in 3 languages. Could you please help me solve the problem by examining the attached excel file. What am I missing? I can not find.

My knime version 4.4.1
Sysytem Windows 10

@umutcankurt I tried some variations also with different characters, Under MacOS all seems to work fine. I still saw strange problems under Windows 10. It could display the characters in R/Rstudio (to some extent).

@Iris , @ScottF maybe you could check out this examples and see if there is a special problem with encodings under Windows 10. I have toyed around with several UTF settings but to no avail.

One thing to try next would be to import the data from excel directly via R, but I fear there is a display problem under Windows 10 within some (all?) nodes.


Hi @umutcankurt @mlauber71 , once again, it works without any issues on my side with Excel Reader (Windows 8.1):

All 41 columns are displaying well.


Hi All

I can confirm that the characters are displayed wrongly in the table view on Win10 - I created a ticket for that (internal reference: AP-17532), so hopefully it will be resolved in the next release.

@umutcankurt unfortunately I have no idea for a workaround :frowning: . Maybe its merely a displaying error and the nodes work as they should, despite the wrong display?

@all: Thank you so much for the thorough testing!
Best, Lukas


I tried several workarounds with R nodes via CSV, Excel and Parquet files. The problem always is that some characters are not displayed correctly within nodes in KNIME.

  • bn (Bengali)
  • hi (Hindi) although that should have worked in the past
  • ko (korean)

All these characters should be part of a ‘regular’ UTF-8 encoding though …


Exactly, they don’t get displayed correctly, but I think they get read in and handled correctly - you can still configure and apply other nodes with these special characters with the expected results:

e.g. filtering or applying a rule engine (the rule I used: $3$ = "বিমানবন্দর" => "gotcha!", displayed as image
). So in principle you can build your workflow, only type the respective characters in an editor that displays them nicely, then copy&paste them to where you need them.

But yeah, even it is “only” a displaying issue: it is ugly and annoying and needs to be fixed :wink: Where the root caus is? I have no idea, because as you said and found out, these characters are part of UTF-8 and they get displayed properly in the annotations… maybe the font in the dialogues is lacking these characters and thus displays an emtpy box? :man_shrugging: but that’s only speculation


Hi; @LukasS
Thank you for the temporary solution. But since I need to add many words, it is not possible for me to edit it manually. I hope the new knime version will be fixed. Again, thank you all for the research and all the suggestions.


As additional info.
When I read the file from @umutcankurt in “ExcelReader”. I have the same result as he has with the “Google Sheets Reader”. So a bit different then his results. I am on a Win10 (10.0.19042.1237) and using a Knime 4.3.4

When I attach a “Tika Language Detector” to the “ExcelReader”. The Coulmn 3 is identified as bn-bengali


Cannot display knime google table viewer 3 language out of 41 languages.

  • .bn - Bengali
  • .hi - Hindi
  • .ko - Korean

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

Hey all,

as @marvin.kickuth found out, this apparently is a Windows 10 issue where it misses some supplemental fonts. So if you install these like so

it should work (it did for me with korean; Windows restart required).

Thanks to @umutcankurt for bringing this up once more!