Help with Google Sheets viewer displaying character in different languages.

Help with Google Sheets viewer displaying character in different languages.
how do i solve this problem. Or can you share an example?

Cannot display knime google table viewer 3 language out of 41 languages.

  • .bn - Bengali
  • .hi - Hindi
  • .ko - Korean

Hi @umutcankurt , can you try with UTF-16? UTF-8 is usually enough, but some languages need something beyond UTF-8

Hi; @bruno29a
I tried now but the result is negative. the problem persists.

I am sorry to hear @umutcankurt .

I’m assuming that they show properly in Google sheet, correct?



Hi @umutcankurt , just to see if it’s Google Sheet related or your Knime’s character encoding, could you try these? Copy and paste one of these text into:

  • Table creator
  • A CSV, or txt or Excel

And see how they look in Knime? If they display, then it would be something between Knime and Google Sheet. If they don’t display, then it’s not Google Sheet related, but rather something with your Knime.

1 Like

Excel Reader No

CSV reader

CSV Reader UTF change

Change UTF - 2

Hi @umutcankurt , it looks like it’s not necessarily Google Sheet related, but rather some character encoding related to your Knime, or to Knime in general.

Would it be possible to share this data in a file (txt, or csv, or excel), so we can have a look? Hopefully someone can figure this out.

Also, have you tried pasting this in a Knime Table Creator node?

unsuccessful unfortunatelytest_s.xlsx (9.9 KB)
The attached excel file is useful for you to try.
A,B,C Column languages not displayed

Hi @umutcankurt , on my side, it’s working fine - well almost everywhere. Here are the details:

Table Creator:
Copy paste from your Excel file, it pastes well in the node:

And executing the node, the results display well too:

When I copied it into a text file via Windows’ notepad, it pasted well:

But when pasting via Textpad, it did not work well:

Similarly when opening the file created by notepad via Textpad, it gave me this warning, and could not display properly:

Personally, I would have thought that Textpad would be able to, and notepad not to.

It works well in Notepad++ (both pasted as new or opening the file created by notepad).

Opening the file from File Reader worked well when I switched to UTF-8:

It may have to do with your system or your Knime.


Hi @umutcankurt , just to add what I also don’t have any issues opening your Excel file with the Excel Reader. The display is fine:

Note, I can’t see where the encoding can be set in the Excel Reader, all to say that I did not have to set anything. I just opened the Excel file, and that’s how it shows in the Preview. It shows correctly.

Similarly after executing the node, the results look fine:

My Text file encoding is set to Default in my Knime preferences (File → Preferences → General → Workspace) Can you check yours?


Hi; Many thanks for this great detailed review. :+1: Now I changed the settings to factory settings, I did not try, the error did not go away, but I will try by restarting my knime.


I have not changed. Can you send me a screenshot of your settings? where am i wrong or what am i missing.

Hi; @ScottF
Where do you think the problem or missing setting could be? I couldn’t detect it. Can you help me?
What am I doing wrong.

KNIME version could be the problem

1 Like

Hi; maybe it’s a version difference, but it’s a strange situation. I haven’t been able to find the cause yet, I tried different things, but the result is negative. @bruno29a I’ll take a look if you share the version and settings.
My KNIME 4.3.4

Hi @umutcankurt , my default encoding setting is Cp1252. Yours is set to Cp1254, which is different:

That could explain it

EDIT: I set mine to Cp1254, and it still displays properly in my Excel Reader…


Hi; @bruno29a Thank you for the answer. Any idea how I can solve this situation? And your setting (workspace) screen editor picture, also what is the knime version ?

Hi @umutcankurt my settings is like yours, except that it shows Cp1252. But you can add whichever you want via the “Other” option.

For my Knime version, it’s the latest, 4.4.1.

I’m not sure how to solve this for you. Not sure if it’s Knime related, or system related. If it is the latter, upgrading to 4.4.1 will not change resolve this.