High IO load and server responds slowly

#1

Hi. I have a workflow API on AWS KNIME Server. With a small flow of API requests, the server works well. But with the growth of the number of requests at some point the volume of requests to the disk increases dramatically. As a result, the API starts to work very slowly.
We tried to increase the server parameters (up to 8 CPU cores and 32 GB of RAM), but the effect has not changed
We also tried using the Job Pools mechanism, but the result was the same.
What could be the problem?

0 Likes

#2

We solved the problem. The reason was that during saving the workflow on the local machine, invisible nodes from neighboring workflows were added to it (for unknown reason, looks like bug), and when uploading to the server, the workflow greatly increased in volume.
We created new folder inside Local workspace, created new Knime workflow and copy and paste all visible nodes from problematic workflow into new workflow. After that all works well

0 Likes

#3

Hi Sergey,

Glad to hear this is resolved! To better understand what happened, what exactly do you mean with “invisible nodes”?

Cheers,
Roland

0 Likes

#4


First picture - nodes as I see in Knime Analytical platform
Second picture - nodes in exported workflow (as folders) after unarchiving.

I have no Amazon RedShift connectors in the workflow, but this nodes exists in other workflows

0 Likes

#5

Hi Sergey,

That is certainly unusual, I have not seen this behavior before. Can you please check the timestamps of the superfluous nodes to see when they were created? Did the workflow originally contain those nodes (e.g. because it got copied from another workflow), and then the nodes were deleted?

Cheers,
Roland

0 Likes

#6

Hi Roland.
I don’t know how to check timestamp of invisible nodes.
Originally workflow do not contain this nodes. The situation could be as follows: I mistakenly saved another workflow under the name of this one. And then saved the desired workflow under the name of the this one.

0 Likes

#7

Sergey,

Can you look at the Outline panel within KNIME AP and see if there are icons ways off the main canvas?

The outline panel can be enabled under View-> Outline

The picture below shows what you may see. My main nodes are visible, but by accident I drug two nodes way off the canvas. I’ve done this before and it was aggravating, because I turn the outline panel off to save real estate. With multiple monitors and especially when using Remote Desktop applications this can happen without noticing.

0 Likes

#8

0 Likes

#9

Hi Sergey,

Just wanted to quick follow up if this also occurs in other workflows? Or was this an isolated incident?

Cheers,
Roland

0 Likes

#10

At the moment, this is the only such incident. If there are more, I propose to return to this discussion

0 Likes

#11

Got it, then let’s keep an eye on it. Will close this for now.

Cheers,
Roland

0 Likes