histogram view: side-by-side view loses color


being still very new to Knime, I am confused about the "histogram view" in combination with the "Color  Manager": While the "stacked view" works well (attachement: middle image), once I switch into the "side-by-side" view I lose all colors but every thing else remains the same (attachement: right image). However, for my data only "side-by-side" view makes sense.

Is this a bug? How can I visualize two classes color-coded in a side-by-side view histogram? And how can I format the axes to be nicely presentable?

(A related question: is there a good example what "aggregation column" does? For me, the y-axis of a histogram always shows the frequency. I have read the explanation several times and looked for example, but it does not yet make sense to me other than if the aggregation column actually contained the frequency for the column represented on the X-Axis.)

Knime version: KNIME 2.10.3 (64 bit with all extensions)





the bins are shown in gray in the side by side view since it is not enough space to display them side by side. As soon as the size of each bin is wide enough to display the bars side by side they are also colored. To increase the bin size increase the image size by either resizing the window or soming into the visualisation this should automatically increase the bin size as well if not adjust its size with the bin size slider of the Visualization Tab.

The aggregation column can be used for example to visualize the sum of the income of a certain age-group.

Unfortunately the lable representation can not be adjusted.



OK, I understand that the labels themselves cannot be adjusted. But while scatter plots offer additional formating options (right-click on the axis), histograms appearently do not offer these options regarding "notation", "tick policy", and "mapping methods"; the same goes for setting the lower and upper limits for X and Y.

Woooooot, enlarging the window acutally does bring back the color! And now I know what the aggregation column does.

Thank you!