Hive Connector issue

#1

I need to connect to Hive on HDP 2.6.5, from my Windows KNIME desktop.

Hive Connector is configured with the following parameters:

;ssl=true;transportMode=http;httpPath=/hive;sslTrustStore=/mypath/mytruststore.jks;trustStorePassword=mypassword

This is what I get:

ERROR Hive Connector 0:59 Execute failed: Could not create connection to database: Connection to database ‘jdbc:hive2://myhost:443/;ssl=true;transportMode=http;httpPath=/hive;sslTrustStore=d:/Users/myUser/Documents/datalake-truststore.jks;trustStorePassword=changeit’ timed out

The specified host is accesible to me, outside KNIME.

Thanks,
Fernando

0 Likes

#2

Hi @peleitor

is it possible that you are connecting through a proxy? Is any HTTP or HTTPS proxy configured under File > Preferences > General > Network Connections?

Also, have you already tried to use the connect string outside of KNIME?

Also, are you connecting to Hive directly or through KNOX?
If KNOX, I think httpPath=/hive probably isn’t quite right and should be something like

httpPath=gateway/<clustername>/hive

(adjust as necessary for your environment).

  • Björn
0 Likes

#3

I am trying both directly and via Knox.

How do you specify the certpath in Windows path syntax?

Eg. d:/Users/myUser/Documents/datalake-truststore.jks

fails

ERROR Hive Connector 0:63 Execute failed: Could not create connection to database: unable to find valid certification path to requested target

Thanks!

0 Likes

#4

Hi @peleitor

sorry, for the long delay. You have to set the Java system property javax.net.ssl.trustStore by adding the following line to knime.ini:

-Djavax.net.ssl.trustStore=d:/Users/myUser/Documents/datalake-truststore.jks

If your jks file is password protected (probable) you also have to provide the password:

-Djavax.net.ssl.trustStorePassword=ThePassword

Restart KNIME for this to take effect.

Best,
Björn

0 Likes