How and where to change temp file path for knime server ?

Hello Team

I am using knime server 4.8 on aws ubuntu 18.4
here when i run wkf data stored in the temp folder of ubuntu

it taking space during run… and an error occurred
so in want to change the path of temp file …

how to change it and where changes need to put ?

Hi @navinjadhav,

What kind of error do you get?


workflow stops… due to space issue .

How much disk space do you have overall, how much free space is left and how big are the tmp KNIME files? All job related tmp files are stored in /jobs/job-id/tmp, and this folder be deleted latest once the job is being discarded, by default 7 days after execution. You could try set this parameter com.knime.server.job.max_lifetime=<duration with unit, e.g. 60m, 36h, or 2d> in knime-server.config to a lower value to safe some disk space.

I have two space …
1 - 50GB
2. 250 GB

knime server is running on aws instance
where directory SRV is on 250gb where jobs and workflow
and directory opt is on 50gb where knime AP and knime server instalation is here
and temp directory is holding cachedata when workflow in running state
due that cachedata in temp directory disk space isssue occers
so that i want to move running cachedata to 250gn space not in temp.

Temp files are holding data while workflow is running so it goes around 11gb to 15gb… it varies.
depends on workflow

com.knime.server.job.max_lifetime I already set to 3 days.
I am not worried about this space bcos this space goes from 250gb…

Hi @navinjadhav,

do you use the executor of the server also in GUI mode? This would explain why there are KNIME related files in /tmp folder, as this is the standard temp directory for non-executor use of KNIME Analytics Platform. You can change that parameter in GUI mode via Preferences → KNIME or directly, vie client profile using this parameter /instance/org.knime.workbench.core/knime.tempDir=<your-desired-temp-dir>
or in knime.ini via this option<your-desired-temp-dir>