How can I use the or function with Rule Engine node?


Hi everyone,
There are different values ​​in each row of the 3 columns in the table you see. I want to open a 4th column and bring these values ​​one under the other. I was able to do the first one using “Not” but it gets errors on other data. When I wanted to use “or”, I couldn’t succeed. NOT ($Tckn$ = “?”)=> $Tckn$ data comes with this code but NOT ($Tckn$ = “?”)=> $Tckn$ OR NOR NOT ($Vkn$ = “?”)=> $ $Vkn$ OR OT ($ID No$ = “?”)=> I can’t get $ID No$ results, how can I do it?

Hi and welcome to the KNIME Forum,
You cannot check for a missing value with = "?" because “?” is a valid string. There is a semantic difference between the literal string “?” and a missing value, which we just render as a question mark (but in red and with the circle around it so it is not confused with a literal “?”). For your problem, this means that you have to use the MISSING operator of the rule engine node. If you want to fill a new column with the first non-missing value from other columns, you can also use the Column Aggregator node with the “First” aggregation function. You just have to uncheck the checkbox for missing values.
Kind regards,

1 Like