How do I debug this?? Ungroup node error = Execution failed in Try-Catch block: Length must not be larger than capacity.

Hi @alabamian2 , I’m happy to hear that you found an alternative that was successful.

Based on what you did, it seems like may be the ungroup reached a certain limit that it could not handle, but with the chunk loop, it was able to overcome it as the batches would be smaller.

Still something that perhaps the Knime team could look into - the can use your dataset of 1.5.GB to try and see if they can reproduce it.

But at least, the chunk look is a good alternative. Thank you so much for sharing.


Be aware that DOS batch files do not process file names with spaces in them properly. Windows doesn’t care, but DOS does.
Try putting underscores in the place of spaces in the" KNIME preference 03052021 3pm.epf" filename.

1 Like

Hi @Bob_Nisbet , the full path is enclosed in quotes, so it’s ok:
-preferences=“C:\Users\Brightline\Desktop\KNIME PageSpeed API task scheduler\KNIME preference 03052021 3pm.epf”

Similarly for everything else in the command:
“C:\Program Files\KNIME\knime.exe” which is the executable
-workflowDir=“D:\knime-workspace\SEO\PageSpeed API” alright, not a good example here as there is no space, but if your workflow name had space, and therefore would create a folder for the workflow with space in the folder name, it would still be ok.

EDIT: Just to add also, technically it’s NOT DOS. DOS would not accept these names even in quotes.
For example, Program Files would be referenced to as PROGRAM~1. But this is Windows Command Line, so "Program Files" in quotes is accepted by the command line.
And similarly for UNIX/Linux too, you can access files/folders with spaces in their names when enclosing with quotes, which I believe was not possible in the early ages (or you can escape the space like Program\ Files)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.