How to add table in new Email Sender(labs)

It’s very useful to add report into emails on KNIME 5.3.0.
But the table view seems not showing well in mail body.
What’s the best way for adding table view in mail body?

Hi there @eddy0620 -

I think this might be more a function of the Table View settings inside the component than anything else. Have you tried the “Compact” setting for Row Height?

2024-07-12 14_13_32

That gives this:

2024-07-12 14_13_25

For the benefit of others, I assume you are also starting from this WF example on the Hub:

Yes, I used this workflow for test. But not shown very well of tables in my mail box.

@ScottF It had big arrows of table title. :rofl:


this is sadly mostly out of our control. Every e-mail client has its own restrictions towards what it is able/allows to display with HTML. I would recommend to configure the table view as basic as possible to avoid these artifacts.