How to connect to embedded Derby database


I would like to connect to an embedded Apache Derby database (created with InstantJChem from ChemAxon). I have installed the Derby database driver, but am unsure about the URL synthax. To clarify, the database is located in a folder on my PC, so it should be something like:


Since I do not get a connection with this URL (ERROR     Database Connector                 Execute failed: Could not create connection to database: null)  there is obviously something wrong with the synthax. I would be gratefull for some pointers regarding forward and back slashes etc. Also I am unsure whether the part after ExampleDB is actually needed.

Many thanks!



In the examples on they use forwardslashes instead of backslashes as pathseparators. Very unix-minded. Also that leading double forwardslash seems to be not needed.






No luck so far:

ERROR     Database Connector                 Execute failed: Could not create connection to database: Driver "org.apache.derby.jdbc.ClientDriver" does not accept URL: jdbc:derby:C:/Users/

Playing around with derby, something started to tickle: are you using the derby-server, or trying to read the database-data file directly ?

The latter aproach will not work.

If you download the derby installer you will find documentation with it, and i recomend you read up to here : Derby_10/docs/html/getstart/index.html

there is explained how you can connect to it using a syntax like so:  


Hi Ellert,

I'm trying to read the database file directly, this is embedded Derby. I don't think I should need a port number.


i am trying pretty much the same as Dr_Van_Nostrand:

*Knime 2.11.3 on a unix workstation

*Apache Derby DB (chemaxon) in a local directory

*Connection attempt with Database Connector Node using the driver org.apache.derby.jdbc.AutoloaderDriver and the URL  jdbc:derby:[location of my db] without any port

First I had the same error as Nostrand. But after a period of trial and error runs I found out which subfolder of the db location I had to type in so the driver could find the db.

Now I get the followig error: Could not create connection to database: Catalogs at version level 'null' cannot be upgraded to version level '10.5'.

Only hint I found was this:

I tried to define the driver in File -> Preferences -> Data Management -> Connectivity -> Driver Definitions using the Embedded JDBC driver and the versio 10.5 .jar. This changed nothing.

Any comment appreciated!