How to get knime.log updated for each run of a workflow

Hello dear community,

I have two problems with the log files of KNIME.

  1. Not every workflow updates after every run knime.log => What can I do? I don’t know why that is.

  2. How can I make sure that knime.log is updated for each run of the workflow so that exactly the log data of this one run is in the file and not other data? Another problem at the moment is that knime.log is too small, so new log data will be converted to knime.log.old. That shouldn’t be either.

Thank you very very much.

Hi there @Larsus123,

Just to be sure. You are talking about log in “…\knime-workspace\.metadata\knime”?

What are your log file level preferences? If set to WARN then modifying/running workflow which produces no errors or warnings will not update log file obviously. Also if set at INFO you will see no DEBUG data.

You can’t have only log data from that run. You will have previous log data as well.

You can increase log file size. Check here. This link also talks a bit more about logging so feel free to explore it.

Additionally you can enable per workflow logs. This preference together with above mentioned log file level are defined in File --> Preferences --> KNIME.

Hope this helps.

Br,
Ivan

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.