How to install Knime on latest versions of Chromebooks

Hi everyone.

I have seen this question has been asked in the past here but I believe it needs un update since now Chromebooks can easily install Linux apps (as explained here).

However it seems a .deb file is required for the installation to be completed but I haven’t found any deb file available on the Knime website.

Maybe I’m wrong since I consider myself a n00b: Is there anyone who tried to do that?

Hi @fryfella

What makes you think that a .deb file is required?

I’m not sure what Linux distro does the Chromebook use, but a .deb file is basically for Debian-based Linux distos (Debian, Ubuntu, MX Linux, etc) and won’t work on other distros.

I doubt there is an installer for Linux. I think Knime is distributed as a tarball for Linux, not as a .deb package, and should be able to be extracted on any Linux distro.

Here’s a reference: Linux apps on Chrome OS: An easy-to-follow guide | Computerworld

Many thanks for your reply,

Hey @fryfella , thanks for sharing this article. I did some digging, and it looks like the Linux on Chromebooks used to be Debian-based, more precisely based on Ubuntu, and is now Chrome OS is a Gentoo Linux based.

I don’t have a Chromebook to play with, so I cannot confirm what the guy from the article is saying works or not, but based on the article, it looks like you can install .deb files.

However, as I mentioned, Knime does not come as an installer or .deb files (and that’s probably the reason, because it would have to be packaged for specific Linux distro), but as a tarball that you can just untar and use.

I did some digging on this too. If you check Install | KNIME , the instructions are there:
" * Linux: Extract the downloaded tarball to a location of your choice. Run the knime executable to start KNIME Analytics Platform."

So, just download the tarball from the download page: Download | KNIME

Hi @bruno29a and thanks again for your kind replies and patience.

Unfortunately I’ve also tried with the tarball but I can’t install Knime. It could be I am missing something, that’s why it’d be interesting to know if anyone else has found a way.

Hi @fryfella ,
I´m using KNIME on linux (not a chromebook) from the tarball and it works fine. Could you post the error message when you execute it? If your not getting an error via gui, you could try to start knime on the command line to get additional information about the start process.


1 Like

Hi @goodvirus can you please explain a bit better how to do that or reference a tutorial?

just go to your command line, navigate to the folder where you unpacked your knime tarball and use the command


Than you get additional information about the startup.

1 Like

Hi @fryfella , no worries, I’m happy to help. My next moves would be exactly what @goodvirus said.Try to run Knime from the command line and let us know what it returns.

You may also explain what you have done so far. There are a lot of users who run Knime on Linux, though not necessarily on Chromebook, but it should not matter. It should work on any Linux distro.

Well well, I have found how to do that and for those who need a bit more instructions this tutorial is just perfect.

It actually worked as I can open Knime now, but something is wrong with the GUI

Before Knime gets opened I receive this message:

I have even tried the

sudo apt-get install libwebkitgtk-3.0-0

command recommended here FAQ | KNIME but I get the following message

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libwebkitgtk-3.0-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libwebkitgtk-3.0-0' has no installation candidate

Any idea?

Hi @fryfella , the tutorial you shared is just to show you how to extract a tarball. Do you mean that you had not done that up to that point?

You could not launch knime unless you extract the tarball. A tarball is the grouping of multiple files into just one file to make it easier to share, and in some cases it’s also compressed (extension as .tgz as opposed to .tar if not compressed). Just like on Windows, you have to unzip a zipped file before being able to use the application. You can’t run Knime directly from a zip file or from a tarball.

While you may be missing some library as Knime suggested, from your screenshot, it looks like it’s also a memory issue. The system is not able to properly display, possibly because of not enough memory.

For the missing library, the one specified in the FAQ might be outdated. Someone from the Knime team would be better position to recommend what libraries to install.

Just please ignore that tutorial. I wasn’t even able to extract the tarball hence I thought it could be useful to reference that in case someone else need it.

Chromebooks have usually got less RAM than ordinary PCs, but the one I’m using has got 8 GB of RAM which sounds enough for any kind of application…

Hopefully someone from Knime will look into it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.