how to maximise the workbench window

Hello all

Please how do i maximise the Knime window to fill my whole screen.

thanks in advance

Hi @Kwame,
this error is caused by a corrupted workspace. You can fix it quickly by switching to a new workspace. You can then import all your workflows from the old workspace in one go if you select it as a root directory in the import screen.:


1 Like

thanks Gabriel but after selecting switch workspace from the file menu, only half of the window is still covered.

Hi Kwame,
That is strange did you switch to a completely new workspace? Switching the workspace fixed other occurrences of this issue in the past.


Hi there @Kwame,

check this topic for ideas and possible solutions:



thanks for the link but after trying the suggestions, the problem still persists. i have even installed all extenstions and restarted but still remains.

I also tried to uninstall the 64 bits and then tried to download the 32 bit but also had grey area. In addition, the 32 bits had no list of extensions for me to install so i uninstalled it. Now i just downloaded the 64 bits and tried to install again and I receive the pop up that directory already exists. choose a different one. I added s to make the program file read Knimes but after installing,no extention could be installed, and the grey area still remained.

Any help?

Hi @Kwame,

I asked my colleagues and they recommend the following:
delete .metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi from the workspace directory.

Also you should use the 64 bit version of KNIME AP, some plugins do not work with the 32bit version and can only use about 4gb of RAM.



Hi Gabriel

Please find attached the screen when i try to switch the workspace.
Also in my plugins, i cannot find the exact link i should delete as in the other picture attached.



Please find attacehed the correct attachment for the link i should delete. which one should i delete please.

HI @Kwame,

in the switch workspace menu, you need to select a different folder, which will be your new workspace.This should then fix your issue. If not, you need to go to that folder in your file explorer and delete the file workbench.xmi which is located in the folder .metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi



It solved in my case.
Thanks, Gabriel.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.