Grey Area in Knime Workflow Editor


I have been trying to deal with a grey big area in my workflow editor. I’ve tried to reinstall it to expand the editor but without sucess. Does anybody have any idea to help me fix it?

Thank you,

Hi @ericsteinbock -

Do you have a screenshot of the problem you could share? Also, which version of KNIME are you using, and on what OS?


Here it is:

Version 3.6

Hi @ericsteinbock,
try resetting your layout by clicking: View -> Reset Perspective...


@gab1one, It didn’t work either.

Ok have you tried switching to a new workspace?
File -> Switch Workspace

If you don’t have the grey area in the new workspace, you can import the workflows from your old workspace via Import Workflow -> Root Directory there you can select the old workspace and you will be prompted for the workflows you want to import.


Hi Gabriel, I got the same problem. After having installed and restarted Knime I have only access to the left half of my screen. Astonishingly it worked with full screen when I started Knime for the first time. Does not work with different workspace either.

Hi @ruettger,
I am very sorry for the later reply, is this still an issue for you? If so can you please detailed information about your system and your KNIME log? This would help us figure out this problem and fix it.

Hi gab1one,
I am working on a Mac. Now I can see the workflow but only 50% (half of my screen on the left) can be used with KNIME. Did not manage to get the full screen.
Can you help?

Thanks R.

Hi @ruettger

Can you give me a bit more details on that please? Which version of MacOS are you using? Which mac?

Just to double check:

  • Did you try downloading the latest version of KNIME Analytics Platform and uses a new workspace?
  • Did you try starting KNIME with the -clean parameter?
  • If these tips don’t help: Can you please post your KNIME log?


I have the same issue here. I’m working on MacOS 10.13.6. I downloaded the latest KNIME version. I created a new workspace. I even tried the startup with -clean. I still only get half of the window.
I am attaching the KNIME log for you.

knime.log (1.1 MB)


Hi Antje,

I hope we can triage this problem successfully together, in the log everything seems to be normal to me though/

does this happen with previous versions of KNIME AP, or just with the one you just downloaded? Can you please try with the latest nightly build?


I already tested the preview (nightly from 25.11) which was fine.
The lastest nightly build is also fine.
I have 3.6.1 running without problems.
For curiosity, I downloaded 3.6.1 and updated it to 3.6.2. Even that works…
To be sure, I tried to reproduce the problem - and it’s gone.
I cannot explain if there is anything different to what I did yesterday. But I repeated the installation of 3.6.2 twice with the same result of half screen grey yesterday. The installer did not change overnight, I guess.

I am happy for you that the problem is gone, too bad we could not identify it’s cause though.


Hi Gabriel,

I have recently installed KNIME and i am having a similar issue. The first time i logged in it looked fine and when i tried to move it around i now have half a grey screen. I have tried the following without success:

  • starting a new workspace
  • loading another workspace
  • clicked reset perspective

I am on a Windows 10 (Version 10.0.12134 Build 17134) and on Version 3.7.0

1 Like

Hi @matteast92,
did you try downloading a fresh version of KNIME Analytics Platform (e.g. the archive, not the installer) and try with that? Also sometimes a restart of your computer might help. Please report back if the problem persists.


Hi @gab1one,
I have tried downloading it from the archive and restarting my laptop but hasn’t worked. See below screenshot i get on opening KNIME. Any help would be greatly appreciated!


Hi @matteast92,

I notice from your screenshot that your application window is maximized; if you click on the maximize button again and then drag-resize the application window - does it in anyway affect the size of the gray area? … and if you reset the perspective while the application window is not maximized?

Hi @quaeler,

Thanks for looking at this. I have tried both these and still doesn’t seem to work, screenshot below is after i reset the perspective as you suggested

How strange - if you maximize the workflow editor pane - by either double clicking on the tab for your workflow, or clicking the maximize square in that editor pane - does it maximize to half-width of the application window or full-width?