How to reset Workflow in KNIME Webportal


I have questions about Workflow execution in KNIME Webportal.

  1. What is the way to edit workflow deployed on Server?
    There is HDFS Connector node in my workflow.
    And my local environment can’t connect to HDFS, but the Server can.
    So when I want to edit some node connected HDFS Connector node, then I have to try like this.
    (1) Open the workflow as new Job on Server
    (2) Edit some node connected HDFS Connector node
    (3) Save the job as new workflow
    Question: Is there any less complicated way?

  2. How can I reset workflow with every run on Wenportal page?
    There are some Widget node in my workflow.
    I ran a workflow that was deployed to a KNIME server from the KNIME Analytics Platform, but it didn’t reset after running.
    And when I run this workflow from the KNIME Webportal, it skips the widget nodes that have already run.
    Question: Is there a way to reset it every time I run it from a Webportal page?


Welcome to KNIME Forum @hhkim I am more than happy to help you.

  1. First, the way to edit a workflow that it is already upload to the Server, as you mentioned is with “Open as new job on server” option. Where you can track the nodes and if so, to be able to know the where is the error.

  2. When you upload a workflow to the KNIME Server from the KNIME Analytics Platform you have the option “Reset the workflow(s) before upload”

So every time the workflow is run it will be reset.

I hope this can help you, but if you have any further questions or thoughts please, let us know.

Thank you for your help.

So after upload a workflow to the KNIME Server, do I have to reset the workflow manually before running it in KNIME Webportal?

Sorry, but the image did not upload correctly.

You can see now the image above.

Thank you for your guidance.
Your answer helped me understand it.

Happy to help,

If you have more questions, please let us know :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.