How to use FTP Connector and File Transfer nodes?


Until recently I used the FTP Connection (Legacy) node together with the Download (Legacy) node for downloading files through FTP. Since these nodes are outdated I wanted to give it a try with the FTP Connector and File transfer nodes. However I cannot get the File Transfer node to work (I have added the Source File System Connection port to hook it up to the FTP Connector node).

The FTP Connector nodes seems to work fine as I get the proper connection. How should I then configure the File Transfer node in order to download the files I want? Source is set to FTP but the File Browse button does not show any path other than /

Accessing and browsing through the ftp folders and files with the legacy nodes works fine.

Please advise/Evert

Hi ,

Apologies about the late response here. Would you mind sending a screen shot of the configurations of both “new” nodes you are using? I am curious if we are missing anything that describes where the path’s are pointing. I will also do some testing on my end to try and figure out why you are not able to browse with the File Transfer Node, and verify if that is the correct node to be using since the update.



It now seems to work as it should. I believe the problem was that I had not selected the proper working directory in the FTP Connector node to begin with.


1 Like

So, I am back here with a new problem. It seems that the ‘Transfer Files’ node now no longer takes URIs as variables but straight Paths instead, so I should be able to bypass the Path to String/String to URI nodes:


But now the loop stalls when trying to read the first file with

ERROR File Reader 0:930 Execute failed: The data row has too many data elements.

The variable output from the Table Row to Variable Loop Start reads:

(LOCAL, /home/evehom/Data/Databases/Glide/MolPort/FTP/2022-02/iis_smiles-000-000-000–000-499-999.txt.gz)

Please advise/Evert

That error message looks more like a node configuration or file content problem. Can you read the file when you manually select it in the config window?


I cannot read the file explicitly either, it gives the same error message. However it works with the File Reader (Complex Format) node, even with the path set as a variable.

Best wishes/Evert

Interesting (and good!) that it works with the complex format. If you still want to get it to work with the File Reader, I found a thread that looks similar.

The significant settings were:

  • support short data rows
  • manually setting the row separator (it was KNIME AP on Windows vs KNIME Server on Linux)

maybe also

  • support changing file schemas (for loops - advanced settings)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.