How to use the | character as delimiter while reading a CSV file?

In Excel I can split cell using the | character as delimiter, but doesn’t work in knime
What am I missing?

Hi,

Please post a workflow with your data that does not work so we can help you with this. Thank you!

4 Likes

maybe escape slash is missing. I agree with @victor_palacios

1 Like

This is the workflow:
image
And I can read the file, but it’s only 1 column.


This is the configuration:

Hi I tried a csv with pipe and it worked smoothly.
Have you checked the other settings? E.g. Quote char, escape char and (maybe) even encoding of your file?
br

1 Like

You could always do a regexreplace on the pipe character before the split as a troubleshooting option.

Perhaps it is a character encoding issue?

1 Like

Hi @manugor

Could you perhaps upload a small actual sample file, with similar content like you already have shown in the screenshot? That takes away people having to guess and will probably lead to a quicker solution :wink:

1 Like

this interface doesn’t allow a
registros-date_20220913190557_0-part-3 .txt (2.0 MB)
(this is a RAR file, but had to change the extension so this interface allowed the upload)

Have tried a Text manipulation box and doesn’t recognize the character.

csv_read.knwf (11.4 KB)

I had to reduce the number of rows in your data in order to meet the upload limitations, but it will work when you point it to your full file. You have to love a good 1 node solution!

The culprit was indeed the encoding type under advanced settings.

2 Likes