HTTP Status 404 – Not Found error for KNIME Server BYOL AWS Marketplace Instance

After rebooting the instance for the KNIME server get an error for 404 as shown below figure. Also tried to restart the Tomcat server manually. t3.large instance was used in AWS in order to install the KNIME server BYOL AWS marketplace. not able to access the link https://HOSTNAME:8080/knime/webportal/ and https://HOSTNAME:8443/knime/webportal/. Also tried without using “webportal”.

Knime Server Version: 4.12.3

Hi @KashyapGohil , this means that the page you are trying to access does not exist.

Are you sure you got the correct URL? Can you tell us why you are trying to access 2 different ports? And the default URL for accessing the Knime webportal is http(s):///knime - I know you said you tried without “webportal”, but it sounds like you are going by trial and error.

Can you please check with your server admin for the correct port and url?

hello, @bruno29a

t3.large instance was used in AWS for the KNIME server BYOL AWS marketplace.

As shown in the below image we already check that 8080 and 8443 were working.

Also, we had check knime service already active.

But at the time of accessing the URL getting the same error 404 for apache tomcat as I mentioned in the first image. initially, we were able to access the URL successfully but after rebooting the instance we are getting an error.

Can you check catalina and localhost logs? I’d expect to find some errors related to the KNIME webapp in there.

1 Like

Thanks for the additional info @KashyapGohil . If the URL used to work, I am not sure why it would not anymore. As per @Marten_Pfannenschmidt , can you check the Catalina logs?

Hello, @Marten_Pfannenschmidt @bruno29a

I had check recent Catalina and localhost logs, not understanding the error in the log file. I have attached the text file for both the log file please find it below.

catalina.2021-07-21.log (35.1 KB)
localhost.2021-07-21.log (22.8 KB)

Hi @KashyapGohil

the logs hint that the server repository does not exist:

com.knime.enterprise.server.config.ServerInitException: com.knime.enterprise.server.config.ServerInitException: Server repository ‘/srv/knime_server’ does not exist

Can you make sure this is the right folder and the service user has sufficient permissions? In case you want to use a different folder/path as server repository, you can also adjust the path in <>\conf\Catalina\localhost\knime.xml

Hi @Marten_Pfannenschmidt

I don’t know the correct path for the server repository.

I have changed path ‘/srv/knime_server’ to ‘/opt/knime/knime-srv-4.12.3’ in the knime.xml file and also getting the same error. As shown below, I have checked Catalina log.

Thank you.