https://forum.knime.com/t/string-or-binary-data-would-be-truncated-error-with-db-writer-node/21986/10

Continuing the discussion from "String or binary data would be truncated" error with DB Writer node:

I’m writing to give an update of this problem that I posted two years ago, thanks to Tobias, his method using “DB Table Creator” to define the size of nvarchar columns before DB writing works well.

I actually ignored the issue that I posted (am using legacy database writer) these years, today when I’m trying to optimize one of my workflow by replacing the legacy database writer (which is slower) to DB writer I recalled this issue again, and this time I managed to follow Tobias’s method, and it works to write correct Chinese charators into the database!

All I need to do is:
create the correct DB table by setting nvarchar(255) (doesn’t need nvarchar(max) actually) in DB Table Creator node, of course I need to de-check the “use dynamic setting” checkbox before doing this. Then use DB Writer or DB Inserter to write the table, change type mapping to “string → nvarchar” before writing.
image
image

Thanks Tobias! A late appreciation…
@tobias.koetter

2 Likes

Thanks for posting an update! It’s always nice to see longstanding issues like these get resolved. :slight_smile: