I can't install KNIME on linux Centos 7

I installed KNIME 4.7.4 on linux Centos 7.
But nothing helps, I don’t even know what to do.
Installed a bunch of libraries:

sudo yum install wget
sudo yum install atk
sudo yum install at-spi2-atk
sudo yum install cups-libs
sudo yum install libXcomposite
sudo yum install libXdamage
sudo yum install libXrandr
sudo yum install libxkbcommon
sudo yum install libgbm
sudo yum install libxshmfence
sudo yum install libX11-devel

!SESSION 2024-02-22 17:06: 06.631 -----------------------------------------------
java.vendor=Eclipse Adoptium
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:- reset-nosave-application org.knime.product.KNIME_BATCH_APPLICATION-workflowFile=/home/gilbert/Knime/knime_4.7.4/knime-workspace/test.zip
Command-line arguments:- os linux-ws gtk-arch x86_64-reset-nosave-application org.knime.product.KNIME_BATCH_APPLICATION-workflowFile=/home/gilbert/Knime/knime_4.7.4/knime-workspace/test.zip

!ENTRY org.eclipse.osgi 4 0 2024-02-22 17:06:07.784
!MESSAGE application error
java.lang.UnsatisfiedLinkError: /home/gilbert/Knime/knime_4.7.4/plugins/com.equo.chromium.cef.gtk.linux.x86_64_95.0.6/chromium-4638/libequochro.so: / lib64 / libstdc++. so.6: version `GLIBCXX_3.4.20’ not found (required by /home/gilbert/Knime/knime_4.7.4/plugins/com.equo.chromium.cef.gtk.linux.x86_64_95.0.6/chromium-4638/libequochro.so)
at java.base/jdk.internal.loader.NativeLibraries.load (Native Method

CentOS 7 is not supported by KNIME any more. Please use a more recent version.

  1. Install the necessary libraries:
    sudo yum -y install bzip2 wget gcc gcc-c++ gmp-devel mpfr-devel libmpc-devel make

We downloaded gcc version 4.8.5 20150623 (Red Hat 4.8.5-36)
Now it needs to be updated

  1. Download gcc-8.2.0 from the website:
    Index of /pub/gcc/releases/gcc-8.2.0

  2. Unzip the file:
    tar zxf gcc-8.2.0.tar.gz

  3. Create a separate build folder for our work, we should not spoil the source code:
    mkdir gcc-8.2.0-build
    cd gcc-8.2.0-build

  4. Setting up the configuration:
    …/gcc-8.2.0/configure --enable-languages=c,c++ --disable-multilib

  5. Building a library:
    sudo make install

  6. Now put gcc in the path:
    “export PATH=/usr/local/bin:$PATH”
    “export LD_LIBRARY_PATH=/usr/local/lib64:$LD_LIBRARY_PATH”

  7. Checking the gcc version : gcc --version

If you want to reinstall the Linux server and reinstall the application, find the value
“cd gcc-8.2.0-build”

and reinstall the paths:

“export PATH=/usr/local/bin:$PATH”
“export LD_LIBRARY_PATH=/usr/local/lib64:$LD_LIBRARY_PATH”

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.