I can't open the Job after Upgrade

#1

Hello,

I updated the server to the 4.9 and Knime to 4.0 nad i cannot open the job anymore


Here the error

could you help me ?

Gianpoalo

0 Likes

#2

Hi @geppopompo,

I assume you are trying to open a job in remote editor, e.g. by double-clicking it? Can you confirm that both server and executor have been updated to the newest versions?

Cheers,
Roland

0 Likes

#3

HI @RolandBurger

Yes that is what i try to do.

How can I check the executor version installed?
Server is 4.9

Thanks !

0 Likes

#4

Dear @geppopompo,

the fastest way is probably to download the logs from KNIME WebPortal admin pages and check the RMI executor logs for the startup message which points out the version number.

Best,
Marten

0 Likes

#5

I have a similar issue when trying to open/debug a job that was executed after the update.
knime_server_executorupdate_issue
Basically, during the update, I exchanged the .war file to upgrade the KNIME Server, plus I ran the update-rmi.sh on the update site “https://update.knime.com/analytics-platform/4.0” to update the executor.
The former part worked well, as WebPortal now tells me that we’re running KNIME Server 4.9.1:
Webportal491
The latter part terminated with the message “No updates found” in the command line, which surprised me.
The RMI executor logs show that I’m still running "KNIME Analytics Platform v3.7.2.v201904170949 (Build April 18, 2019) ".

I’m a bit confused by the update guide as it says to use the update site for v4.0. But does that even work for v3.7 that I have? Maybe that’s the problem?
Also, the error message when opening the Job in KNIME A.P. references the version of KNIME Server, not the executor version, strange!

Thanks for any help!

0 Likes

#6

Hi @pcps-afa,

In the case of updating from AP 3.7.x to 4.0.x, you actually have to do a fresh installation. We implemented some major changes in between those two versions, so that updates are not possible.

We updated the documentation to reflect this, see here https://docs.knime.com/2019-06/server_update_guide/index.html#knime-executor under “Installing a new KNIME Server Executor”

Can you please try to install a fresh executor?

Best,
Roland

0 Likes

#7

Cheers @RolandBurger - I guess I misread the update guide. I thought 3.7 was still OK for the update.
My bad.

I’m now checking how to re-install the Server executor in this guide and it tells me to download the “KNIME + all free extensions” package from the “public download page”.
Sadly, I can’t find that package download on that page:

Help (again)!

P.S. Perhaps you can still note it down as a minor improvement that the error message you get when opening the job is misleading, as it said that we’re still running Server v4.8.2, which is not the case. It should say that the executor needs to be updated.

BR Alex

0 Likes

#8

Good point, “public download page” is a bit misleading here, since it refers to this page: https://www.knime.com/knimecom-product-downloads-2019-06 (which is public, but not as easy to find as the one you found :wink: ) Specifically, you these are the downloads you need:
Windows: https://download.knime.com/analytics-platform/win/knime-full-latest40-win32.win32.x86_64.zip
Linux: https://download.knime.com/analytics-platform/linux/knime-full-latest40-linux.gtk.x86_64.tar.gz

I’ll look into the warning message, it is definitely misleading :slight_smile:

Cheers,
Roland

1 Like

#9

@RolandBurger Thanks for that!
Alright, I now have the very big executor files for the executor update :slight_smile:

Now, because I want to make sure I understand correctly so I don’t mess up my KNIME Server executor; this is what I propose to do (after making a backup):

  1. Delete all contents of the “knime_executor” folder on my Linux Machine (thus de-installing the v3.7 executor)
  2. Move the entire contents of the .tar.gz file into that folder

However, I doubt that this will seamlessly work, because the following things are not clear to me:

The following line in the Update guide is not very specific: Set relevant preferences in KNIME and export to <server repository>/config/preferences.epf

Also, I didn’t understand the part with " Similarly, be sure to copy your new knime.ini file (from the KNIME Analytics Platform installation folder) to your server repository ( <server repository>/config/knime-rmi.ini )." Do I have to rename the file and move it to the other folder?! Sounds iffy…

Then in the linked Installation guide it talks about an “installation”, but I don’t have a .jar file to install, like I had in the initial setup of the entire KNIME Server… so I am actually quite confused by the guides. FYI, I don’t have a graphical user interface on Linux. This all has to be done via SSH.

Can you bring some light into the darkness?
Ideally, can you provide details on the exact steps (1, 2, 3, etc) that need to be done to replace the 3.7 with the 4.0 on Linux via SSH?

Thanks & BR
Alex

0 Likes

#10

Hi Alex,

The steps you outlined are correct. However, please backup your knime.ini before deleting the old executor, as you will want to use this one in the new executor as well.
You can safely ignore the suggestion to move the .ini to /workflow_repository, just leave it with the executor.

“Installation” of the executor in this case refers to unzipping it in the correct location.

The part about the preferences.epf is also not important in this context, since preferences are stored in the server’s workflow repository, rather than with the executor.

Cheers,
Roland

0 Likes