Impala Connector

Hi,

I'm getting the following error while trying to use the Impala connector node:

Execute failed: could not create connection to database: connection refuse.

Whereas the hive connector and hive loader are working with same the use id and pwd and url.

Thanks,

Rajesh

Hi Rajesh,

"Connection refused" means that Impala Connector could not make a network connection to the Impala host and port you configured. This could be caused by a firewall (firewall between your machine and the cluster) or the host/port combination is wrong. There is not much we can do from KNIME to tell you what you have to do here. You should ask your cluster admins/IT operations which host/port you are allowed to connect to from your client machine in order to use Impala.

Best,

Björn

 

Hi Rajesh,

have you installed the JDBC driver for Impala that is provided by Cloudera? You can download the driver from the Cloudera homepage. Once downloaded extract the zip file to a directory on your hard disk. The directory should contain a lot of jar files and some pdfs. Once extracted open KNIME and go to File->Preferences. In the preferences dialog go to KNIME->Databases and add the folder by clicking on the Add Directory button. If you now open the Impala Connector node dialog you should see a message that the Cloudera Imapal driver is used once you have applied the new settings. If you need to enter a user name and password make sure to add AuthMech=3 into the Parameters field. For more details about the paramters have a look into the Cloudera-JDBC-Driver-for-Impala-Install-Guide.pdf in the extracted folder.

Bye

Tobias

Thanks Tobias,

i did what you have explained. but i still get the error "Execute failed: Could not create connection to database: Connection refused: connect"

attached my preference file. I can connect to hive same connection settings but not to impala.

 

 

Hello Rajesh,

the dialog settings look good. Are you sure that the Impala Service is running on port 21050 of the given IP address? As Bjoern already mentioned is a Connection refuse error usually caused by a network problem e.g. the service is not running or not reachable due to firewall settings.

Bye

Tobias

Impala connector is working fine, this is due to some wrong configuration on impala cluster with port numbers. it is all working now on the standard port 20150. thanks to all.

I am trying to connect to Hadoop on the Cloudera Quickstart VM. I downloaded the Impala jars and copied them to C:\Program Files\KNIME\plugins folder.

The error I get now is
Execute failed: Could not create connection to database: org.apache.thrift.protocol.TProtocol cannot be found by org.apache.hive.jdbc_1.1.0.cdh5_13_0-knimebd-20171201

Parameters
hostname: 192.168.177.128
port: 21050
database: default
parameter: AuthMech=3
username:cloudera
pass:cloudera

It does not show Impala Cloudera driver. How to install the driver on the KNIME 3.5.2 version?

Hi,
please read my comment a bit further up on how to install the driver.
Bye
Tobias