Impala driver and Kerberos not working after KNIME update to 4.6

Hi everyone,
until version 4.5.2 my configuration of Impala Node (Cloudera Impala JDBC 2.6.4.1005) works but updating KNIME to 4.6 is giving me this error on the console:

ERROR DBDriverRegistry Database driver wrapper creation failed for driver (impala_krb) “impala_krb”.
ERROR DBDriverRegistry Failed to register driver (impala_krb) “impala_krb”.

“impala_krb” is the database driver from Jar archive i loaded in the “Database” section of Preferences → KNIME

Beside that it looks like the new version is giving me problems also with kerberos authentication:

ERROR KerberosControlContribution Kerberos login failed: java.lang.IllegalAccessError: class org.knime.kerberos.KerberosAuthManager (in unnamed module @0x1e5d2f5c) cannot access class sun.security.krb5.KrbException (in module java.security.jgss) because module java.security.jgss does not export sun.security.krb5 to unnamed module @0x1e5d2f5c

Any idea about what is going wrong here?

Thank you in advance for your answers!

Francesco

Hi @francesco.bindella,

Can you verify KNIME was updated to the latest 4.6.x release, and that the Kerberos plugin was updated?

Run all updates, and restart KNIME. If the problem persists, open Help → About KNIME Analytics Platform → Installation Details. On the Plug-ins tab, enter “Kerberos” in the search box:


What org.knime.kerberos version do you have installed?

Cheers,
Sascha

1 Like

Hi @sascha.wolke ,
thank you for your answer.
I currently have KNIME 4.6.4 installed and this version of Kerberos:

I don’t know what happened but today my KNIME installation seems able to connect without any problem :dotted_line_face:
I wasn’t expecting anything when I tried after my last post a few minutes ago, since (as Einstein said) “The definition of insanity is doing the same thing over and over and expecting different results”, but (at least for this time) it looks like I got a different result doing the same thing that wasn’t working in the last days of 2022!
Now I’m ready to jump to version 3.7 :wink:

Great that everything works now :slight_smile: