incorrect page layout (end of page missing?)

The new version of the reporting extension does not paginate reports correctly: it seems that the page break is not read, so the first element of a page is actually displayed as the last element of the previous page.
In my report, each page has an initial title line at the top and two lines of charts following it. In the previous version (labs), pages were created correctly: the first page with its title and graphs, the second page with its title and graphs, and so on. With version 5.2.0, the ‘title’ of the second page is displayed at the end of the first page, the title of the third page is displayed at the end of the second page, and so on.
Thank you in advance for your help and attention

Hi @gio_bi,

How did you put page breaks between report fragments? If you have multiple report enabled components, you can use Report Page Break node in between to apply a page break. And if you are concatenating them using a Report Loop End or Report Concatenate node, then you can enable page breaks between each report fragment by checking the “Insert page break between reports” option in the node dialog.

I hope this answers your quesiton?

1 Like

Thank you so much! I’m using the new Report Loop End node and I hadn’t noticed the “Insert page break…” option.

1 Like

Hi @armingrudd , I’m doing some testing with the reporting extension, and the “end of page” doesn’t always seem to work correctly: in the same report maybe I have 20 pages paginated correctly, and then one where the “end of page” is not handled correctly.
This is an image of the footer of one of the slides: “Key Performance Indicator nr 3…” should be at the top of the next case.
I didn’t understand the logic by which the error occurs: sometimes it shows up after 20 or 30 slides, in this case it showed up already on page 4.
Thanks for any help you can give me.

Good morning, everyone. I would like to kindly know if those who are now testing the new reporting extension nodes have experienced the same problem as mine (the “Insert page break between reports” option does not always work); I have checked the flow several times but maybe I am doing something wrong… Thanks!

Hi @gio_bi and sorry for the late reply,

Is it possible for you to provide me with an example workflow which reproduces the problem?

1 Like

Hi @armingrudd , I am out of the office these days, and I don’t have the tools to anonymize the workflow data. However, last night I did some testing with real data and the “nightly version” of Knime (which solves some report pagination problems), and the problem did not occur to me. By January 3, however, I will share a test version of the workflow. Thank you for your helpfulness and best wishes for a peaceful 2024.

1 Like

Hi @armingrudd , this is my first time sharing a workflow, so I hope this link is okay:

For convenience I have recycled parts of the “real” workflow, I hope it is understandable enough despite some labels in Italian. if you have any problems we’ll be in touch. thanks for your time


1 Like

Hi @armingrudd , did you have a chance to verify the anomaly with the workflow I shared?
Thank you

Thank you @gio_bi for reminding me. I bookmarked your post but somehow missed it.
I will check it today.

1 Like

Dear @gio_bi,

Thank you again for providing the example workflow.
Running the exact workflow for a few times, I was unable to reproduce the problem. But, I added a few copies of the Report PDF Writer node to the workflow and executed them at the same time, then I was able to see the problem.

So, may I ask if this is also the same for you? Does this problem happen only when running multiple Report PDF Writer nodes?

Hi @armingrudd , no, with only one “Report pdf writer” node, with the workflow in the configuration I shared. I’ve tried with both win 10 and win 11, Knime version 5.2.0, in the office but also with my home pc (which obviously has much less security controls), always getting an incorrect page break (curious note: only one page break is incorrect, I’ve never had cases with two or more incorrect breaks).
Even right now, if I run the workflow I shared in my public space, without changing any parameters, I get an incorrect page break (pg 23 of 30, KPI3 after KPI29). Is there any verification I can do independently?
Thank you for your time

Yes, I could also reproduce with one wirter node using a zipped installation.
I created a ticket for the problem: UIEXT-1550

Thank you so much for reporting this.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.