Installation of R is stuck on defining Path to R Home

Dear Knimers

I’m trying to get under Windows10 in Knime 4.3.0 R up and running again. I’ve been through this ordeal before using Windows7 and Knime 4.1.3 where I got it working by using all the great tips given in this topic:

I’m using Anaconda to keep track of the environments (which does work for Python happily; the py3-knime environment is created and working). The RStudio environment which is created by Anaconda gives me R version 3.6.1.
I’ve installed the version 1.8-6 of RServe using RStudio (I tried the binaries and an own compiled version; both give the same error in the end) and installed Cairo.

When I try to change the path to the R Home I get the following error on an invalid R executable:


but in RStudio R.home() gives this:
afbeelding

The knime.log shows this:

I tried the tip provided here:

RServe starts without problems, but it does not make any difference, the error remains.

Does anyone have a clue what could be the real issue here?

The problem got solved. It had to do with authorisations my employer applies to our WIndows-10 pc’s. I installed R and RStudio not through Anaconda anymore, added Rserve again (latest version 1.8-7) and now it’s working as before.

3 Likes

Glad you found a solution - thanks for posting it!

@ScottF indeed very glad :wink:
It does make things easier for my colleagues when they migrate too.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.