Installing extensions built with 3.6.0 in KNIME 3.5.3


#1

Hi Team,

Schrodinger started building our extensions with 3.6.0. Now, is that possible to install these extensions in KNIME 3.5.3?

Thanks
Ravikiran


#2

The short answer is that “it depends”. Only way to find out is to try installing them and see if they will install and if they then work.
Steve


#3

Actually I am getting the below dependency error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Schrödinger Base types Feature 4.3.12.201808161950 (com.schrodinger.knime.feature.base.feature.group 4.3.12.201808161950)
Missing requirement: Schrödinger types and core files 4.3.12.201808161950 (com.schrodinger.knime.base 4.3.12.201808161950) requires 'bundle org.eclipse.ui [3.109.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: Schrödinger Base types Feature 4.3.12.201808161950 (com.schrodinger.knime.feature.base.feature.group 4.3.12.201808161950)
To: com.schrodinger.knime.base [4.3.12.201808161950]

I confirmed that in 3.5.3, the version of org.eclipse.ui is 3.108 and in 3.6.0, it is 3.109.
So it is very clear that installing our 18-3 extensions (which are built with 3.6.0) will not work in KNIME 3.5.3.

Am I right?


#4

Correct. However, I don’t think that your extensions needs that very specific version of org.eclipse.ui. You probably forget to set a version range on the dependency and then during build it will be auto-populated with the currently available version as the minimum. Therefore always add version ranges on dependencies!