Installing Rserve 1.8-6 on macOS 10.15. (Catalina)

I’m on a different computer than before, and tried to get the R snippets working in Knime. I remember that this was already quite difficult on macOS 10.14 (Mojave), however now I have the feeling that it seems impossible on macOS 10.15 (Catalina). I have installed and reinstalled Xcode, and the commandline tools (also separately). Additionally XQuartz, Clang and GNU Fortran have also been installed. Along with several Warnings, when trying to install (using the “R CMD INSTALL Rserve_1.8-6.tar.gz” in Terminal) I also get following error:

clang -Wall -g -O2 -D_THREAD_SAFE -pthread -o forward forward.o http.o http_tools.o server.o tls.o websockets.o md5.o sha1.o base64.o date.o ulog.o chandler.o rscript.o -ldl -lssl

ld: library not found for -lssl

clang: error: linker command failed with exit code 1 (use -v to see invocation)

make[1]: *** [forward] Error 1

make: *** [all] Error 2

ERROR: compilation failed for package ‘Rserve’

  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/Rserve’

  • restoring previous ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/Rserve’

As the error seems to be related to the ssl library, I have additionally installed a brew version of OpenSSL which did not help either… I have also looked into doing following:

sudo installer -pkg \ /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg \ -target

however, on macOS_10.15 there is no Packages folder any longer…

Has anyone successfully installed Rserve on a Mac running 10.15, or does anyone have any further suggestions?

Cheers, Sebastian


Hi there @s_rupp,

welcome to KNIME Community!

Maybe this topic can help you. It has dedicated part regarding MacOS.


1 Like

Hi Ivan,

Thanks, yeah I have ben through that topic, and tried everything in there as far as I could understand. Like mentioned above the one thing from that topic, that does not work on Catalina is installing the headers:

sudo installer -pkg \ /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg \ -target

as there is no longer a Packages folder with the headers pkg included.

Hi @s_rupp,

that is the best I can do. Considering this is (more) R and MacOS related maybe looking/asking somewhere else isn’t a bad idea. But who knows maybe someone from KNIME Community can help as well :wink:


This part does not work any longer. I am not sure how I overcame the problem the last time.

From my recollection it involved updating the xcode app/tool on MacOSX.

Unfortunately I am not knowledgeable enough to provide a compiled version of RServe. I even wrote to the developer but to no avail. And yes I googled it but it seems for the knowing people this task is to benign to be described to the mortals … :slight_smile:

1 Like


this is a known issue and we have a script for that. Gonna send you the script via PM tomorrow morning.

We are working on a proper docu for the R extension :slight_smile: that links that script.



It would be great if you could share that. Is there an idea when that would be. I also would be interested in an DM :slight_smile:

Thanks Mark,
that would be awesome,


1 Like

@s_rupp @mlauber71

just sent you the script. Let me know if the script did not work!

@mlauber71 I hope we will get that doc online sooner than later.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.