Installing Spatial Processing node - error during installation

I have read the older posts already. I am running Knime 5.2.1 and trying to install the spatial processing nodes. I am pulling from Kifer the installation files. During installation, I get this error message:

Cannot complete the install because one or more required items could not be found.
Software being installed: KNIME Spatial Processing Nodes 1.3.0.202204201712 (ch.res_ear.samthiriot.knime.shapefilesaswkt.update.feature.group 1.3.0.202204201712)
Missing requirement: KNIME Spatial Processing Nodes 1.3.1.202204201712 (ch.res_ear.samthiriot.knime.shapefilesaswkt 1.3.1.202204201712) requires ‘osgi.bundle; org.knime.workbench.core [3.7.0,5.0.0)’ but it could not be found
Cannot satisfy dependency:
From: KNIME Spatial Processing Nodes 1.3.1.202204201712 (ch.res_ear.samthiriot.knime.shapefilesaswkt.feature.feature.group 1.3.1.202204201712)
To: org.eclipse.equinox.p2.iu; ch.res_ear.samthiriot.knime.shapefilesaswkt [1.3.1.202204201712,1.3.1.202204201712]
Cannot satisfy dependency:
From: KNIME Spatial Processing Nodes 1.3.0.202204201712 (ch.res_ear.samthiriot.knime.shapefilesaswkt.update.feature.group 1.3.0.202204201712)
To: org.eclipse.equinox.p2.iu; ch.res_ear.samthiriot.knime.shapefilesaswkt.feature.feature.group [1.3.1.202204201712,1.3.1.202204201712]

How do I overcome this issue?

Hi @TallPaul63 ,

according to their GitHub repository, it is currently only available via its own update site (go to Preferences -> Install/Update -> Available Update Sites and add it there according to the above link). @samthiriot FYI

Best regards
Steffen

1 Like