Interactive Table (local) - View unavailable in components?

The Interactive Table (local) view doesn’t seem to be compatible with Component View Configuration… It works fine with Table View and Table View (Labs), but Interactive Table (local) doesn’t show as an option. Is this expected for some reason, or is it a bug?

My goal was to build the Interactive Table (local) node into a component and then force it to open in the “Always On Top” setting. Now that I think about this, I am not sure this would work as intended since it may just be placed inside a component view window without that setting option…

Hi @iCFO , the Interactive Table and the other (local) nodes are part of an old KNIME AP release and, you are right, do not show up in the component’s composite view.

I recommend you to go with the JavaScript-based Table View node or the new Table View (Labs) node if those fit your requirements.

Cheers,
Emilio

I think this is the only node that has the “Always On Top” window option at this point, which is the functionality required.