Intermittent fail to load for widgets and table editor in v4.5.1.

Hello - we’ve recently installed v4.5.1. and seem to be having intermittent issues with, for example, table editor node not displaying content, i.e. execute and view or interactive view options. The window pops up but remains blank. Furthermore, when you try to close the window it stays put for several seconds (more than 10) before reacting. The same appears to be happening with some widgets also, e.g. single value selection. I thought it was just me but one of the team reported this in our planning session today and when I tried to add a table editor to a workflow I had open I got the same thing. Unfortunately I am struggling to reproduce the error but we never saw it before 4.5.1. Just wondering if anyone else has come across it and/or any ideas. I’ll try to reproduce in an example but it is rather proving an embarrassment when we are demoing to users.

1 Like

Hi @SteveThornton -

Sorry for the trouble. This sounds quite similar to a bug we have noticed internally (AP-18435) and for which we have a solution in place.

If you are able to install the newest nightly build, would you be able to test and see if this resolves the issue for you?

Thank you - we’ll try that today - can you give any guidance on how to merge the nightly build into our existing install ?

Looks to be impacting Javascript Plots also…

Have downloaded the nightly build into its own folder and run KNIME from there. Seems to be OK although not immediately responsive. Do you have any more background to the AP-18435 bug - I don’t seem to be able to find it in any changelog ? I’ll ask some other team members to check out also.

Hi Steve -

Glad you found the nightly build and were able to give it a try.

The reference I gave (AP-18435) is just an internal tracker for our system - those codes usually don’t show up anywhere in a changelog until the problem is fixed, which in this case should be once the next bugfix release for AP happens.

When you say “Seems to be OK although not immediately responsive” can you be more specific? Does this mean the bug is generally fixed but the interactive views don’t display as quickly as you would expect? Or something else?

Hi Scott - maybe we should take this off-line until we have a resolution - there’s a few issues which impact on our server install and executors also.
It looks like the nightly build is OK although difficult to be certain as looks intermittent but could be combinations of version workflow was saved in etc.
I think the ‘slow to react’ may have been a red herring local issue - seems OK today… so far
When I run nightly build I am getting an error during load when immediately try to run 4.5.1. again, will try to attach log message.
We have 4.5.1. executors in use by server now so patching this problem could be troublesome, i.e. introducing newer nodes/code.
We’ll keep testing to try to isolate but lot of variables… older workflows deployed to web portal seem OK currently.


All right, glad to hear that tentatively things are working OK. But if you need additional help please reach out to directly and we can followup there.

I’ve updated ‘support’ with latest observations, but by way of an update… after a bit of Googling I found a previous similar case (actually boiled down to having components inside metanodes) made reference to the browser used for JavaScript views. I changed this from ‘Chromium Embedded Framework (CEF)’ to 'Bundled Headless Chromium ’ and it did seem to make a difference in my case. Working OK at the moment but have seen it come and go before so not counting my chickens. We downloaded the ‘full’ zip archive for 4.5.1. so maybe this setting was included as default. Will update after more testing.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.