"Invisible" columns in Excel

I have a question regarding ‘invisible columns’ in Excel and CSV creations I’m having an issue with. I have a workflow that manipulates data and then pushes it into an Excel Writer and CSV Writer. I then use the file that is created and upload it into another program. It’s a very picky program and when I try and to upload the CSV file that is created by KNIME, I get an error message of “invalid header.” The solution I found is I open the KNIME-created Excel file, delete the farthest-right blank column and resave as the Excel and CSV again, and then the load works. It’s as though the program thinks there is an extra column or some type of header in the blank column. Any ideas what could be causing this? I have even been trying to think if the RowID column in KNIME (which doesn’t get written into Excel/CSV, but is visible in KNIME before writing to Excel/CSV) has anything to do with it because I can’t figure anything else out. Thank you in advance for your help!

Hi @Srb035 .

It’s dificult to help with no workflow or data. If you upload your workflow with data, we can try to help you.


You can try to check Open file option in Excel Writer. When file is open in Excel, press CTRL+T to create table. If table has extra column, you can delete it and save Excel file. Or created in Excel table may help to recognize necessary columns in picky program.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.