Is there a way to assure in Random Forest Predictor, ROC Curves, that the desired parameters appear?

I am working on a QSAR in KNIME, and as a part of the quality assurance of the machine learning model, I would like to generate an ROC Curve after the Random Forest Predictor node. I have tried many ways of configuring it so that the prediction column in the ROC Curve will show activity (Prediction) when the target column is activity. For some reason I am completely unable to have the desired column appear. Would someone be able to help me trouble shout this problem?
Random Forest.knar.knwf (71.0 KB)

Hi @fath1,
I can try to have a look at your workflow but unfortunately the data is not included. Could you please share ta modified version of the workflow that read the input data file from the workflow’s data directory? Alternatively, you may want to share your workflow with the 2 File Reader nodes in the executed state. That will also work fine.

test_data.csv (57.1 KB)
training_data.csv (1018.2 KB)

I was able to upload the data files. Now to check it, the “file reader” node will simply need to be replaced with the “csv reader” node. Thank you very much for any help you’ll be able to provide.

Hi @fath1,
I’ve downloaded and plugged your training and test data files but I’m having an error while running the workflow. Can you please upload a new, non-reset version of the workflow? I don’t think it will be to big in size.

To do that:

[Right click on the workflow to export] → Export KNIME workflow… → [Unselect the option named “Reset Workflow(s) before export” → Finish.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.