Issue with installing extensions through zip file

I’m trying to install the trusted community extensions through zip file method, I wanted to install all the plugins and features that are present in the zip file to be installed.

when I run the below command in the command line prompt it fails with below error-
./knime -application org.eclipse.equinox.p2.director -nosplash -consolelog -r ‘jar:file:/srv/datavol/knime-packages/knime-extension-pkgs/!/’ -d /srv/datavol/knime-full_4.7.4/

can some one please help me like what is the issue in the above command?

There is no possibility to install everything that is on an update site. You have to provide a list of features that you want to install (-i).

we are not using the updated site, using a zip file

If its the same for zip file also then how can we get the list/id’s from a zip file to pass as parameters for -i option?

It doesn’t matter if the update site is online or in a ZIP file.
You can find all command line options for the p2 director at Help - Eclipse Platform. For listing the contents of an update site you can use -list.

Thanks for the update Thor.
I’m fine with the command line options for p2 director but if I list the contents in the zip file it shows like this

so if I wanted to install the highlighted plugin then how should I pass with -i
./knime -application org.eclipse.equinox.p2.director -nosplash -consolelog -r ‘jar:file:/srv/datavol/knime-packages/knime-extension-pkgs/!/’ -i (what should pass here)

In the zip file list all the plugins/features have .jar as names but in the official documentation we just have id vale to pass with the -i option right? so how can I derive it from the above snip

You cannot install plugins you can only install features. If you know the feature file name you can cut the name before the underscore append in order to get the IU name that you pass after -i.

If I wanted to install the highlighted one’s in the below snip

I can run the below command correct?
./knime -application org.eclipse.equinox.p2.director -nosplash -consolelog -r ‘jar:file:/srv/datavol/knime-packages/knime-extension-pkgs/!/’ -i, -d /srv/datavol/knime-full_4.7.4/

This looks correct. Except that you probably don’t want to install a source feature.

Hi Thor,

I tried the command but its showing unable to read repository error

The zip file has all the permissions granted.

I can see in the error its looking for artifacts.xml and content.xml in the zip file but when I listed the files in the zip file it shows artifacts.jar and content.jar (instead of .xml).

can you please suggest how to fix this?

The error message comes from the operating system. The only possible reason is that the user with which you run this command does not have access to the ZIP file.

I ran it with sudo user only and has all the permissions to execute it. Is it something to do about the .xml? since in the zip file its with .jar and its looking for .xml and not able to find in the zip file?

This is a generic error message from the p2 director if it cannot read the repository. In your case the ZIP file cannot be opened in the first place and hence it doesn’t find content.xml (or .jar).
What happens if you run unzip -t ... with the same user on the ZIP file?

I never found these types error while doing this. Well, if you have read about zip file perfectly in detail then you will never face type of errors again. But you can try any other solutions accordingly. But my suggestion Information is everything to use technology at its best.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.