Issue with KNIME Server BYOL AWS Marketplace Image


I’m having an issue where i’m deploying the AWS Marketplace Image for KNIME Server BYOL, it’s successfully deploying and I can SSH into the server instance, Apache Tomcat is running but when I navigate to http://Public DNS/knime

I get a HTTP Status 404 - Not Found error.

Is there any additional steps i’ve missed to get this deployed correctly?

Hi Craig,

Are you trying to access the WebPortal? The URL should be https://“serverURL”/knime/.


Hi Medzi,

That’s correct. I’ve tried that URL with the Server Name being my AWS EC2 DNS address followed by /knime/ and I get the following error;

HTTP Status 404 – Not Found

Type Status Report

Message /knime/

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists

If I navigate to just the DNS address, no /knime/ then I can see Apache Tomcat is running on the instance.

Hi Craig, could it be that you’re deploying on one of the new C5, M5, r5 instances? There is a known problem with that instance type. We’re working on a fix. The easiest option is to switch to a C4,M4,r4 instance type.



Hi Jon,

Thanks for the response, I figured this out last night, I was deploying on an M5 instance. Switched across to a T2.xLarge and it worked fine.

Thanks again!

Thanks for confirming Craig. As I mentioned we’re working on a fix. It’s due to the fact that the workflow repository block device is mounted differently with the new NVMe disks on the *5 instances. Apologies for the inconvenience.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.