Issue with Openbabel translation node


First post here, I've been using KNIME for a while and seem to have found an issue for which I cannot find a solution elsewhere on these forums.

I had KNIME installed and running on a Mac desktop (OSX 10.9) and was compiling a variety of protocols, many of which employed the Openbabel traslator. All worked fine. Unfortunately this particular computer is in the middle of a midlife crisis and is refusing to start up, so I'm doing a complete overhaul. I have therefore passed all my KNIME work over onto my (much newer) Mac laptop - identical software specs to the desktop. However, on this laptop, whenever I try to use Openbabel translator node, I get an error message stating:

"Error while executing....(plugin extension directory)babel.dyld.....Library not loaded: /usr/local/lib/libopenbabel.4.dylib

Referenced from : ...(plugin extension directory)../babel

Reason: image not found"

From this I am gathering that there is a key file missing, however as far as I can tell all the correct extensions have been loaded, and ibabel and openbabel have been installed.  Searching the drive shows that the library libopenbabel.4.dylib exists, albeit in a different location to the one it is looking for it in; indeed the file directory /usr/local/lib/doesnt exist on OSX9 as far as I can tell. Does anyone have any suggestions as how to get around this? I've tried importing the whole Knime folder from my older computer onto the lapop and I still get the same error, suggesting that the error lies outside of the knime folder structure.

Thanks for any help you can give!




Update : problem resolved - I had to install Chemspotlight for Mac (package containing most up to date version of Openbabel for Mac) as the version of openbabel which I downloaded was older.