Issues installing Knime Labs Extension

Hi Knime Community, I am new here and I am currently facing an issue instaling the Knime Labs Extension.

  1. KNIME version 4.6.3
    02 Steps applied:
    02.01. Go to MenuPath: File\Install Knime Extensions
    02.02. Select Knime Labs Extension
    02.03. Click Next, then Click Finish

Warning outcome indicates: “Problem Occurred” ‘Installing Software’ has encountered a problem. A error occured while installing the item:

Click on Details button:
An error occurred while installing the items
session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null → [R]org.knime.pythonscripting.channel.v1.bin.win32.x86_64 4.6.0.v202207221021, action=org.knime.product.p2.actions.ShellExec).
An exception occurred while executing the ShellExec command.
Cannot run program “C:\Users\Node” (in directory “C:\Users\Node Model.eclipse\1406022308_win32_win32_x86_64\plugins\org.knime.pythonscripting.channel.v1.bin.win32.x86_64_4.6.0.v202207221021\bin”): CreateProcess error=193, %1 is not a valid Win32 application.

Would you please assist me on this. Thank sin advance I will appreciate your kind support.

Best regards,

AnthonyCREng

Hi AnthonyCREng and welcome back to the forum,

are you talking about the KNIME Python Integration (Labs) extension? Which Windows version do you have exactly? And is it 32bit or 64bit?

Best
Steffen

Hi AnthonyCREng,

we are wondering, do you have a whitespace or a line break between C:\Users\Node and Model.eclipse\1406022308_win32_win32_x86_64\plugins?

Best regards
Steffen

Hi Steffen, thanks for your kind response. My Windows version is 64 bit.

Thanks again Steffen, I dont understand what is the cause of this issue as I have followed and applied the same method we use to install any extension. In fact just this extension is presenting the issue. Need to solve this in order to complete some exercises derived from a course I am currently developing. Perhaps someone else have experienced the same issue.

Hi AnthonyCREng,

wait. We are talking about different things. I thought you want to install the KNIME Python Integration (Labs) extension. Which is where your error probably derived from. You, however, seem to be trying to install all extensions of the KNIME Labs Extensions category. Is that necessary? I would understand if you need to install all that if you do some profound testing. But that does not seem to be the case. You need something specific for some exercises. Could you ellaborate what exactly you are trying to do?
Could you just install the extensions you really need?

Thanks and best regards
Steffen

2 Likes

It works! You just need to install one extension at the time (not the whole file) otherwise the issue erupts.

Thank you so much Steffen, so kind from you.

Kind regards from Costa Rica.