Issues installing python/anaconda on Windows

I follow the directions and downloaded and installed Anaconda (Anaconda3-2020.11-Windows-x86_64.exe) and the python nodes. However whatever I do I can’t get KNIME to recognize the python directory. It only has the error message: “Failed to execute Conda: The system cannot find the path specified.”

I can find no message in the logs giving a hint of what path it is looking for. I removed and re-installed anaconda, and tried both user and system installation. I also freshly installed KNIME 4.3.2. What is the process for installing?

Hi @DrMatthewClark,

Could you try executing conda --version via the terminal (on Windows, most likely the Anaconda Prompt) and check whether that works or whether it fails with a – hopefully more detailed – error message?

Marcel

1 Like

I get this at windows prompt:
C:\Users\ClarkM\Applications\knime_4.3.2>conda --version
conda 4.9.2

however I apparently also had Pymol installed some time ago so the “anaconda prompt” gives this:
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.

(C:\Users\ClarkM\Applications\PyMol) C:\Users\ClarkM>conda --version
conda 4.3.30

(C:\Users\ClarkM\Applications\PyMol) C:\Users\ClarkM>

I deleted the Pymol reference. This is from the “anaconda prompt” from the anaconda3 installation I have no idea what path it thinks is specified.

The system cannot find the path specified.

(base) C:\Users\ClarkM>conda --version
conda 4.9.2

(base) C:\Users\ClarkM>

have you tried a virtual environment as path?

Is it possible you need to set your Windows PATH environment variable to point to the folder where Anaconda is installed?

Instructions below (and apologies if this is something you are already familiar with):

that did not help. See environment variables. I reset to “base” and so Anaconda is the only path at this point.
image

I think it needs to be set as a system variable (the bottom portion of the dialog), as opposed to a user variable.

ok. I’ll try that again. However, the “standard” Anaconda install appears to deprecate that, and the KNIME instructions don’t suggest that.

Also, does c:\Users\ClarkM\Anaconda3\ actually exist on your system (maybe there’s a typo) and are permissions set so that it’s accessible? Does that path include the typical \bin subfolder and other associated subdirectories?

I realize these are silly questions, but I’m just thinking out loud since this is so strange.

yes honest!


current system path:

At least in the screenshot I cannot see a path reference to anaconda. Maybe you can check out this collection

And start with the official Python integration guide and toy around with these settings:

With anaconda I found you sometimes have to just reinstall everything. And also if you mix some installations via pip not all of them fit well into an (ana)conda managed surrounding.