Java Snippet returns integer

I have a really simple question.
I at trying to apply several math calculations on different columns, thus the most convenient way to do this, is by using the Java Snippet.
The type of those columns is Long. Although, after doing the math calculations, the output returns those values as integer numbers.
These are the simplest calculations I apply and I still, get this result:
out_Acolumn = out_Acolumn/10;
out_Bcolumn = out_Bcolumn/10;

The Java and Knime Type on the Output field, for all those, is Long. (The Input is also Long as I mentioned)
Could you please advise?

Thanks a lot

I just tried out_myvalue = Long.MAX_VALUE and it properly returned a long value. Can you share a simple example (table creator + Java Snippet) that lets me reproduce the problem?
Kind regards,

Hi @AlexanderFillbrunn
Thanks a lot for your response, I tried to do something similar to what you suggested, but I still don’t get the correct results. Most probably I am missing something.
I am attaching a workflow sample of the simplest case of my problem.
Hope this helps to reproduce
JavaSnippet test.knwf (6.4 KB)

Hi there @mucu,

I have checked your example and Long type is returned. Have also seen you flagged first post so I assume you figured it out. Free to close topic?


Hi @ipazin,
Yes I figured it out, it can close:)