Java Table Editor

After update to 4.7 the Java Table Editor does not except the keyboard shortcuts command c and command v. In addition added hyperlinks do not work. The problem does not exist on Windows only on my Mac. I am running the newest MacOs Version. The right-click commands still work correctly. The hyperlink however still does not open the link in a browser.

Hi @Jerry ,

are you speaking of the JavaScript Table Editor that somewhat looks like the following?

I just tested, and copying from cells without editing them is not possible, not in the older and not in the latest 4.7.0. Or are you talking about the cell, when you are in editing mode?
image

Could you further elaborate what you mean by hyperlinks? Did you put some HTML-Links in there that now do not work anymore? Do you maybe have a small example you could share?

Kind regards,
Lukas

1 Like

Hi Lukas,
correct I meant in editing mode. Before it was possible to select a string and copy it to the clipboard with command c and paste it into somewhere else (even another cell in the table) with command v. Now only the right-click mouse commands work. Attached is a simple workflow with a hyperlink which previously opened upon clicking.
Table Editor.knwf (7.0 KB)

1 Like

Thank you very much for the example. As soon as I have access to a Mac I’ll keep you posted!

1 Like

Thank you very much, Lukas
Best regards, Jerry

1 Like

Hi @Jerry,

indeed, this is a bug that we will address (internal reference: AP-19970) - we were are seeing the same behavior as you do in your example. Thanks for that, examples are always valuable! Unfortunately, we don’t know of a workaround for now - how critical is this issue for you? If you tell more about your use case, maybe we find a solution that can work until this is fixed.

We’ll keep you posted when this is resolved. Thanks for reporting in any case!
Kind regards, Lukas

1 Like

Thanks for your message, Lukas.

I do quite a bit of editing of my data with this node. However, until it is fixed I can use the mouse commands.

Best regards, Jerry

1 Like

Hi @Jerry,

we are now in the strange situation that the problem seemed to have sorted itself - for us, copy-pasting and following links does work again, even though we didn’t so anything. Could you please try again and report whether the problem persists for you? Can you also check whether there are any updates available under File → Update KNIME …? I could imagine there are updates for an extension that might have interfered.

Thanks and kind regards,
Lukas

Hi Lukas, thanks for the info. My packages all seem to be up-to-date and the problem still exists. Offcourse, I have not installed the complete set of packages. I can try to include more packages step by step even though I don’t need them. If at some time it starts working I can give you feedback about the package or group made a difference. This will take a little bit of time.

Best regards
Gerald

1 Like

Hi Gerald,

unfortunate - then we have to dig deeper on where the problem comes from. I don’t think its necessary for you to install all extensions one after the other, but thanks for the offer!

Kind regards,
Lukas