javascript nodes result in blank image window (linux)

Hi Everyone,

I ran into an issue when I upgraded my 4.1 client recently and still see the issue when I did a fresh install of 4.2. I am using AutoML which uses javascript interactive nodes. The view window opens but there are no images. I tried with a simple javascript table view and have the same issue. There are no issues showing up in the debug area or in the terminal just this… i am using the default bundled chromium version 83.

Any ideas?
Thanks in advance :slight_smile:Capture

Starting ChromeDriver 83.0.4103.39 (ccbf011cb2d2b19b506d844400483861342c20cd-refs/branch-heads/4103@{#416}) on port 17440
Only local connections are allowed.
Please see for suggestions on keeping ChromeDriver safe.
ChromeDriver was started successfully.
Oct 02, 2020 6:06:57 PM org.openqa.selenium.remote.ProtocolHandshake createSession
INFO: Detected dialect: W3C


the message printed is not an error, but a success message, that Chromium did start up correctly. Can you open the browser developer tools when the view is open to see if there is any errors logged to the console there? Usually F12 should open it or right click somewhere in the window and ‘Inspect’.

1 Like

Hi @albrecht Thanks for the response! I did as you suggest and I got the following result from the devtools console

@albrecht also if I right click in that devtool window the resulting menu is also blank. Thanks for looking into this!


Hi Jason,

it could be that you are missing a system library for Chromium to run correctly. This is a frequent issue on Linux. The easiest way to find out if that is the case is to navigate to the Chromium instance which should be under the location where you installed KNIME, plugins/org.knime.ext.chromium.bin.linux.x86_64_[version_number]/linux/x86_64/
Try to run the chrome executable from the terminal and see if it opens correctly or if there are error messages being printed.

1 Like

Hi @albrecht,

Thanks so much for the suggestion. I did as you suggested and while nothing happened (no chrome window opened) I did get the following from the terminal. Any ideas?

It looks like that your Linux system cannot provide a suitable sandbox for Chromium to run in.
There is two options, either you start the Chromium process with --no-sandbox and --disable-setuid-sandbox arguments, which can be set on the preference page. This is usually a security concern, especially if you are loading external JavaScript libraries.
A better approach would be to provide the sandbox somehow. I have no experience in setting this up, but I found this after a quick search:

1 Like

Hi @albrecht,

Thanks for the response and suggestion. I tried the additional argument as --no-sandbox setting was already enabled. I closed and restarted KNIME but the behavior has not changed.

Did you try setting up the sandbox environment as described in

1 Like

Hi @albrecht

I have not. I don’t have sudo rights on the cluster that I am using. I was hoping since it worked in a satisfactory manner in early 4.1 before the update that KNIME would be able to sort it out with an update. Additionally it seemed that the sandboxing link is for use when chrome does not launch properly. In my case it seems fine with no errors. Perhaps I am mistaken. Any other suggestions would be welcome!



we recently released a new version of KNIME Analytics Platform (4.3) which comes with a new SWT-embedded Chromium. This should work on any Linux environment. Maybe you can give that a try.

Best regards,


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.