Javascript Scatter Plot Error

hi there,

I'm experimenting KNIME and while I tried the javascript Scatter Plot, it gave me this error upon execution & view: TypeError: 'knime_scatter_plot_selection_appender' is undefined.

I tried to google for it but didn't find any similar posts / problems.

Could someone help me on this?

Thank you.


it is easier to get help if you share here the workflow which causes the error.


Thanks Marco for the response.

Actually, the error shows on any workflow samples on the EXAMPLES Server that I tried.  For instance, the "Simple Example for Reporting" in the attached file.  Wonder if it has anything to do with my computer's setup or environment (Windows 7).


Actually that sample workflow doesn't contain any Javascript Scatter Plot node since it outputs to a report. I assumed you added one. I tried to do the same by connecting one to the output of the Sorter node and it works perfectly for me.

Which version of KNIME are you using? Did you alter the configuration of the Javascript Scatter Plot node or are you using the standard one?

You can export anyway the altered sample workflow and post it here.


Thanks again Marco for your help.

Please find my answers to your quetions below:

1. Yes, I added a Javascript Scatter Plot node to the original workflow.  I also tried what you did, connecting the Sorter node or File Reader node, to the plot node.  Both gave the same errors.  I exported the alter sample workflow and attached it here by your suggestion.

2. I'm running KNIME 3.2 (see attached file).  I'm just using the standard JS Scatter Plot without making any changes to the configuration.


Hi Minh,

your workflow runs without a hitch on my side, so I am not able to reproduce your issue. I can only think of a "bad" KNIME installation or a gone wild upgrade from a previous version.

Can you perhaps try with a completely fresh installation and see whether that makes it work?




I removed KNIME and re-installed KNIME twice but no luck.

I wonder if it has anything to do with windows 7.  I'll install some updates and see what happens.

Thanks Marco.


Maybe your Java VM is not what it should be?

I am also on Windows 7 on one of my machines and it works properly.


Just reinstalled Java too haha.  Did not work.  What I'm using most of the time is the corporate computer which does not allow client side Windows updates.

However, the workflow and the node itself worked fine on my home machine that ran both windows 7 and Linux Mint as I tried last night.

I guess this topic can end here uder the conclusion that this work computer needs some freedom.

Thanks Marco!