JavaScript Views do not work anymore in 4.1

Hello,

since upgrading to KNIME 4.1 (Windows 10, both 64bit) the JavaScript Views do not work anymore. Her is the error from the log file:

ERROR ChromeWizardNodeView Could not initialize Chrome driver. unknown error: Chrome failed to start: crashed
(unknown error: DevToolsActivePort file doesn’t exist)
(The process started from chrome location C:\knime\plugins\org.knime.ext.chromium.bin.win32.x86_78.0.3904.87\win32\x86\chrome.exe is no longer running, so ChromeDriver is assuming that Chrome has crashed.)
Build info: version: ‘3.12.0’, revision: ‘7c6e0b3’, time: ‘2018-05-08T15:15:03.216Z’
System info: host: ‘host’, ip: ‘192.168.1.41’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_202’

Here is what I tried so far:

  • brand new KNIME 4.1 with no extensions and with new workspace --> JavaScript Views still do not work
  • Exclude C:\knime form virus scanner --> JavaScript Views still do not work
  • Put integrated chrome manually into JavaScript Configuration in the Preferences --> JavaScript Views still do not work (I also tried Firefox but it does not seem to be supported)

Do you have any idea?

1 Like

Hey @spider,

Can you attach a screenshot of the Preferences -> KNIME -> JavaScript Views panel so I can see which settings you’re currently using?

Thanks,
Ben

Hi Ben,
besides the testing I have always used the default settings:

(see screenshot).

If I use an external Chrome and put this chrome.exe in the preferences of the java script views it does work. But I guess it should work with the default (integrated) chrome.exe, shoudn’t it?

I (and my fellow users) are getting the same issue.

image

Unfortunately our IT is in control of the chrome version we use and it seems we’re still on 76 :frowning: so the workaround doesn’t work for us.

Hey,

So I’ve spent some time looking into this issue. I’m glad you were able to switch to the external Chrome installation @spider, but you’re right, it should work with the default installation. @swebb as you mentioned this workaround doesn’t work for you so that’s no good. I also tried to get AP 4.1 to work with an older v76 installation, but that didn’t work either. Can you try a couple things for me?

First, to get the views to work immediately, try switching to the internal SWT Browser in the JavaScript Views preferences. Hopefully this allows the views to open while we look into this further.

Second, are you able to add chrome.exe to the list of exclusion in Settings -> Update & Security -> Windows Security -> Virus & Threat Protection -> Manage settings -> Add or Remove Exclusions -> Add Exclusion -> Process? I do not know if your IT dept will let you adjust these settings, but that has always helped me and has solved similar issues with Chrome version updates. You may also try this with the folder in the KNIME installation which contains the bundled Chrome version (is v78 still included in the KNIME install?).

This definitely needs to be investigated further, so I will keep talking to people and see if we can figure out whats going on. Windows Defender is the cause of almost all problems we have seen recently, so changing some of the settings may help alleviate the problem.

Let me know if any of these work. I have high hopes for the 2nd option if you can change those settings.

Best,
Ben

3 Likes

I don’t seem to be running windows Defender (but others are) but I’ve had problems with running Electron applications in the past as Chrome tries to write to some folders we’ve got locked down by our domain policy / McAfee.

We did however manage to get IT to give us a surprisingly quick upgrade to Chrome 79 which does seem to work.

I’ll see if I can find any logs my end which may indicate if the application is being blocked and let you know.

Chrome does seem to partially load:

Chrome crashes when I run it from my install directory and it’s possible it’s being interfered with by McAffee.

Cheers

Sam

1 Like

@swebb

Thanks for the update! Great news about the internal update to v79. That makes things much easier.

Of course, please share if you find any thing in the logs. Definitely sounds like an anti-virus problem to me! If this issue comes up again with another user, it would be helpful to have more information. It will also be helpful as we look to solving the problem on our end for future releases.

Thanks again,
Ben

1 Like

After updating to KNIME 4.1.1 neither the external (recent und reinstalled) Chrome nor the internal does work. There are no warnings or errors in the log while KNIME tries to open the external Chrome and closes it right after a fraction of a second.

What to do now?

1 Like

Hi @spider -

Have you tried adding exceptions for Chrome in your antivirus program? This worked for another user today:

3 Likes

I cannot do this but I have copied Chrome 80 to another directory that is excluded form antivirus programm since I do not see a possibilty to installed Chrome into another directory. in the first place.
It does not work either. I see an window opening and closing within a fraction of a second. Is the version 80 of chrome a problem?

I downgraded KNIME to 4.0.x where the internal chrome does work as before.

Interesting. Let me check and see if there are any updates from the devs on our side. Sorry for the trouble.

1 Like

I’m facing the same/similar issue in KNIME 4.1.2, as is a colleague who recently did a first-ever install of KNIME - though he’s on a slightly earlier version maybe 4.1.1.

I’m unable to open the interactive view of ‘Line Plot’ node. Relevant preferences are defaults i.e. to use internal web browser (default system browser is also checked, which in my case would be Chrome 80). Also preferences for javascript views are set to use bundled chromium 78 as per screenshots from other users above.

Log file error when attempting to open the Line Plot interactive view, in case relevant:

!ENTRY org.eclipse.ui 4 0 2020-03-13 22:28:52.099
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.IllegalArgumentException: Argument cannot be null
at org.eclipse.swt.SWT.error(SWT.java:4514)
at org.eclipse.swt.SWT.error(SWT.java:4448)
at org.eclipse.swt.SWT.error(SWT.java:4419)
at org.eclipse.swt.widgets.Dialog.error(Dialog.java:198)
at org.eclipse.swt.widgets.Dialog.checkParent(Dialog.java:164)
at org.eclipse.swt.widgets.Dialog.(Dialog.java:127)
at org.eclipse.swt.widgets.MessageBox.(MessageBox.java:97)
at org.knime.ext.seleniumdrivers.multios.ChromeWizardNodeView$2.run(ChromeWizardNodeView.java:381)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:37)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4213)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3820)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:680)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:149)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

1 Like

Thanks for the feedback - we’re still working on it from this side. Sorry for the trouble.

1 Like

Is there any update on this please?

Hey @cpa99dcs,

Which OS are you running on?

It would appear that this works again for me in 4.2 :smiley:

Hopefully for others also?

3 Likes

Nope, I get the same (or similar) errors with a new KNIME 4.2 installation with an existing or new workspace:

ERROR ChromeWizardNodeView            Could not initialize Chrome driver. unknown error: Chrome failed to start: crashed.
  (unknown error: DevToolsActivePort file doesn't exist)
  (The process started from chrome location C:\knime\plugins\org.knime.ext.chromium.bin.win32.x86_83.0.4103.116\win32\x86\chrome.exe is no longer running, so ChromeDriver is assuming that Chrome has crashed.)
Build info: version: '3.12.0', revision: '7c6e0b3', time: '2018-05-08T15:15:03.216Z'
....

A solution is to install Edge (the successor of Internet Explorer from MS) and then select in the Preferences -> JavaScript Views the upper pane the “internal SWT browser” for displaying javascript views.

4 Likes