Jitter in scatterplot views


I was trying a few datasets (random data, Iris), but it seems that the Jitter control is not enabled (at least in: Polynomial Regression (Learner), Linear Regression (Learner) with KNIME 2.7.2, Win7, both 64 bit). I think in these cases the cause is that it is not possible to select nominal columns, but there might still be overlapping values. Is this an issue, or this is by design? Do you plan to support jitter with numeric columns? Or do you plan to extend these algorithms in some way to have nominal columns in training columns?

(I think of an acceptable workaround like giving alpha value to the colour of points to see where are multiple items. Do you have better?)

Thanks, gabor

PS.: The Execute and Open Views action's name is a bit misleading as it opens only the first view, not all.

Hi Gabor, 

You are corerct, we don't currently have Jitter options enabled in scatterplot views for numeric values.  I'll open a feature request and propose a few of your suggestions.  Also, thanks for the heads up on the misleading action name, we have logged that as well and tagged it for 2.7.4. 



Thanks Aaron, that will be a nice improvement.

I have to admit I was suggesting a new name for the action for wrong reasons, maybe as multiple nodes could be selected, so the plural form is ok. (Maybe Execute and Open First Views would be better name (or change the action to open all views), but I am unsure.)