Just updated to Knime 3.7 and all my knime extensions are gone....

I tried to install the extensions again by going under File -> Install Knime Extensions. However I receive this error message:

image

Please advise.

Hi @hungerfordwm -

Is it possible you are on a VPN, or on a network with a firewall that is blocking connection to the update site? Are you able to use a different internet connection to test?

The update sites are up and running so I’d say most likely it’s a connection problem from your side. If you still have trouble on a different connection can you report back? Sorry for the trouble.

@hungerfordwm, did you actively activate the ‘partner’ update site (as per your screenshot) or was that enabled by default? It’s true that this site wasn’t only until ~3min ago but it’s been fixed now.

Thanks for catching it. That update site isn’t enabled by default.

  • Bernd

Bernd - that’s a good catch. I suspect what may have happened here is that @hungerfordwm disabled update sites to install extensions from a local USB drive during training, and then manually enabled them later, to include the partner site.

@hungerfordwm, does that ring a bell? Correct me if I’m wrong.

Scott,

It’s certainly possible that happened. However, whatever “has been fixed now” has now allowed me to update and install my extensions. I may be good at this point. I had a few extensions by some third-parties that I’ll have to install and I probably don’t remember at this point how I did it the first time around, but if I have a problem I’ll post the question.

Thanks for the help!

Will

Scott or Bernd,

Now that I am installing my extensions, I repeatedly have been getting this error message:

Knime%20error

I vaguely remember having a similar error in the past but do not know what I did to resolve the memory issue.

Will

Perhaps you changed settings in the knime.ini file to address the memory issue? That’s discussed here:

https://www.knime.com/faq-0#q4_2

Scott,

That discussion states:

How can I increase the Java Heap Space for KNIME?

In the KNIME installation directory there is a file called knime.ini (under linux it might be .knime.ini ). Open the file, find the entry -Xmx512m and change it to -Xmx1024m for example. You may also consider to change the -XX:MaxPermSize=128m option and increase it to 256m or even 512m , depending on your computer’s main memory. Note, that you main memory must be at the very least the sum of both values. (See also the answer for rarely observed problems while increasing heap space under Windows). If you use the developer version you have to edit the run configuration: "Run -> “Open Run Dialog…” -> tab “Arguments” -> field VM arguments -> enter -Xmx1024M.

However, I do not have an entry in the Knime.ini file that begins with Xmx or an entry with XX:MaxPermSize. Here is what I see in the Knime.ini file:

-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
–launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834
–launcher.defaultAction
openFile
-vm
plugins/org.knime.binary.jre.win32.x86_64_1.8.0.152-01/jre/bin
-vmargs
-server
-Dsun.java2d.d3d=false
-Dosgi.classloader.lock=classname
-XX:+UnlockDiagnosticVMOptions
-XX:+UnsyncloadClass
-Dsun.net.client.defaultReadTimeout=0
-XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot
-Xmx25000m
-Dorg.eclipse.swt.browser.IEVersion=10001
-Dsun.awt.noerasebackground=true
-Dequinox.statechange.timeout=30000

1 Like

I can see it - you have a value of -Xmx25000m, which should be plenty. I’d assumed that memory might be the issue because of the java heap space error, but maybe it’s not.

I see in your screenshot that some specific extensions are popping up in the error message. Perhaps it is the Chinese text processing extension that is giving you trouble? If that’s not it, I may need to pull in help from another KNIMEr to diagnose the problem.

To my knowledge I’m not trying to download a Chinese text processing extension.

Weird. Can you confirm that the memory setting is seen by KNIME? E.g. go to File -> Preferences -> General -> Click “Show heap status” and hover over the little memory bar that you find at the bottom right of the application. Does it show in its tooltip some number close to 25G?

If that’s not the problem, then I suggest restarting with “-clean” added to the knime.ini (above “-vmargs”). If that doesn’t help, then I would make note of the registered update sites and remove them, confirm the removal (that part is important), then add them again and try again. If that doesn’t help either, then I would re-install and accept that something is broken with your installation.

Alternatively. you can try these options also in a different order.

Hope this helps.
Bernd

Bernd,

The current Heap status is 90M of 241. It doesn’t strike me as that being the problem.

I’ll try your other suggestions…

Will

What does the tooltip say when you hover over it? E.g. in my case it looks like this:
heap

It says Heap size 191 of total: 228M max: 228M mark:

It doesn’t receive the -Xmx25000M then. Is it the wrong knime.ini file? You can find a (slightly modified) copy of all the parameters in help -> about knime -> configuration. Do you find the values in there?

You could double check that by adding some custom property to the end of the knime.ini file and then restart, e.g. -Dfoo=bar should be somewhere in that text.

Bernd,

So sorry to be difficult, but I don’t find a configuration tab or link under the help tab -> about KNIME. I did however find in my KNIME folder a configuration folder and when I click on config.ini I see this text file:

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Thu Dec 06 17:11:00 EST 2018
org.eclipse.update.reconcile=false
eclipse.p2.profile=KNIMEProfile
osgi.instance.area.default=@user.home/knime-workspace
osgi.framework=file:plugins/org.eclipse.osgi_3.12.100.v20180210-1608.jar
equinox.use.ds=true
ds.delayed.keepInstances=true
osgi.bundles=reference:file:org.eclipse.equinox.simpleconfigurator_1.2.1.v20180131-1435.jar@1:start
org.eclipse.equinox.simpleconfigurator.configUrl=file:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.product=org.knime.product.KNIME_PRODUCT
osgi.splashPath=platform:/base/plugins/org.knime.product
osgi.framework.extensions=reference:file:javax.transaction_1.1.1.v201105210645.jar,reference:file:org.eclipse.osgi.compatibility.state_1.1.0.v20170516-1513.jar
osgi.bundles.defaultStartLevel=4
eclipse.p2.data.area=@config.dir/…/p2/
eclipse.application=org.knime.product.KNIME_APPLICATION

Would this be what you are looking for?

Will

Hey @hungerfordwm,

The “Configuration” can be found under “Help -> About KNIME -> Installation Details” (last tab in list). Can you find the value there?

Also, no need to be sorry. We’ll figure your problem out :slight_smile:

Best,
Christian

Christian/Bernd,

I think that this is what you were looking for:

*** Date: Friday, December 7, 2018 at 1:26:35 PM Eastern Standard Time

*** Platform Details:

*** System properties:
WEKA_HOME=C:\Users\WH275\wekafiles
applicationXMI=org.eclipse.ui.workbench/LegacyIDE.e4xmi
awt.toolkit=sun.awt.windows.WToolkit
ds.delayed.keepInstances=true
eclipse.application=org.knime.product.KNIME_APPLICATION
eclipse.commands=-os
win32
-ws
win32
-arch
x86_64
-showsplash
-launcher
C:\Program Files\KNIME\knime.exe
-name
Knime
–launcher.library
C:\Program Files\KNIME\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834\eclipse_1630.dll
-startup
C:\Program Files\KNIME\plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
–launcher.overrideVmargs
-clean
-vm
C:\Program Files\KNIME\plugins/org.knime.binary.jre.win32.x86_64_1.8.0.152-01/jre/bin\server\jvm.dll
eclipse.home.location=file:/C:/Program Files/KNIME/
eclipse.launcher=C:\Program Files\KNIME\knime.exe
eclipse.launcher.name=Knime
eclipse.p2.data.area=@config.dir/…/p2/
eclipse.p2.profile=KNIMEProfile
eclipse.product=org.knime.product.KNIME_PRODUCT
eclipse.startTime=1544189712148
eclipse.stateSaveDelayInterval=30000
eclipse.vm=C:\Program Files\KNIME\plugins/org.knime.binary.jre.win32.x86_64_1.8.0.152-01/jre/bin\server\jvm.dll
eclipse.vmargs=-server
-Dsun.java2d.d3d=false
-Dosgi.classloader.lock=classname
-XX:+UnlockDiagnosticVMOptions
-XX:+UnsyncloadClass
-Dsun.net.client.defaultReadTimeout=0
-XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot
-Xmx25000m
-Dorg.eclipse.swt.browser.IEVersion=10001
-Dsun.awt.noerasebackground=true
-Dequinox.statechange.timeout=30000
-Djava.class.path=C:\Program Files\KNIME\plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
equinox.init.uuid=true
equinox.statechange.timeout=30000
equinox.use.ds=true
file.encoding=Cp1252
file.encoding.pkg=sun.io
file.separator=\

Will

Just to be sure: Did you try setting the -Xmx25000m to -Xmx4G in the knime.ini? Just as a sanity check.

I just did that and am relaunching Knime.