Keras and TensorFlow Version Mismatch

Hello,

I am receiving an error message that indicates a mismatch between the Keras 2.1.6 and TensorFlow 1.8.0 installed in my Python environment. In the Knime Python Deep Learning Preferences section, the TensorFlow 2 Conda environment indicates that I require a 2.2.0 version as a minimum. How can download the required TensorFlow Conda 2 environement?

Thanks,

Alex

Hello @TE499OP,

KNIME AP can create/download the required if you create the Env via KNIME AP.
https://docs.knime.com/2020-12/deep_learning_installation_guide/index.html

But just to clearify - are you using Anaconda 2 or 3?

BR,
Sven

1 Like

Hi Sven,

I am using Anaconda 2.0.3

Thanks,

Alex

Hi @TE499OP,

and which version of Python do you use? TF2 needs at least Python 3.6.

BR,
Sven

My Python version is 3.7.

I just upgraded to Anaconda 3.

Hi Sven,

I have followed all the instructions in the link you sent, but the error is still persisting. Attached is my log file.Error_Log_2021-06-16.log (576.4 KB)

Thanks,

Alex

Hi Sven,

Any ideas?

Thanks in advance,

Alex

Hi Sven,

Following up. Any ideas on the cause of the Keras and TensorFlow error?

Thanks in advance,

Alex