Keras Network Learner stuck on loading when using validation data.

I’ve been trying to fit a simple CNN to a dataset. If I don’t use a validation split, the Keras Network Learner fits the network in a few minutes. If I try to use the optional validation data port, the learner gets stuck on loading (I tried letting it run for 2 hours before giving up).

I tried DL Python Network Learner and with it I was able to fit the same network with or without validation split just fine.

I don’t know what could be causing this behaviour.

KNIME version 4.4.2.v202110181012
KNIME Deep Learning - Keras Integration version 4.4.1.v202108230956

Thank you for letting us know, I’ve reported this internally.

Update: I’ve installed Keras Integration on another machine with:
KNIME version 4.5.1.v202201200941
KNIME Deep Learning - Keras Integration version 4.5.0.v202111291525

On both machines I tried running ‘03_Train_MNIST_classifier’ workflow from EXAMPLES modified to use a 10% validation split. On the KNIME 4.5.1 machine the Learner successfully fit the network in 3 minutes. The 4.4.2. machine has been stuck for 40+ minutes.

So, works for me on 4.5.1, doesn’t work on 4.4.2.

1 Like

Update 2: I’ve installed KNIME 4.5.2. on the first machine (in addition to 4.4.2., from self-extracting archive), because it seemed faster than transferring workflows and data to the second machine.

Using validation data does not work. So looks like it’s NOT a version issue.

Could you share the information about the machines? OS, Windows, version, etc.? Thank you.

Sure, the first one is a Virtual Machine running on a server, the second one is a laptop.
Here’s info from msinfo32:

machine_1.txt (3.6 KB)
machine_2.txt (3.2 KB)

1 Like